
Chapter 1

Introduction to 
Autodesk Revit 

Architecture 2010
After completing this chapter, you will be able to:
• Understand the basic concepts and principles of Revit Architecture 2010.
• Understand different terms used in Revit Architecture.
• Understand the parametric behavior of Revit Architecture.
• Start the Revit Architecture 2010 program.
• Learn about different components of the User Interface screen of Revit Architecture.
• Access Revit Architecture 2010 Help and Tutorials.

Learning Objectives
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INTRODUCTION TO Autodesk Revit Architecture
Welcome to the realm of Autodesk Revit Architecture, a powerful building modeler that 
has changed the outlook of the building industry about computer aided designs. Autodesk 
Revit Architecture is a design and documentation platform that enables you to use a single, 
integrated building information model to conceptualize, design, and fi nally document a 
project. Its integrated parametric modeling technology is used to create the information 
model of a project, collect and coordinate information across all its representations. In 
Autodesk Revit Architecture, drawing sheets, 2D views, 3D views, and schedules are a direct 
representation of the same building information model. Using its parametric change engine, 
you can modify the design at any stage of a project. These changes are automatically made 
and represented in all views of a project, resulting in the development of better designs, along 
with an improved coordination. The use of Autodesk Revit Architecture provides a competitive 
advantage and a higher profi tability to architects and building industry professionals. 

 Autodesk Revit Architecture AS A BUILDING 
INFORMATION MODELER
The history of computer aided design and documentation dates back to the early 1980s 
when architects began using this technology for documenting their projects. Realizing its 
advantages, information sharing capabilities were developed, especially to share data with 
other consultants. This led to the development of object-based CAD systems in the early 1990s. 
Before the development of these systems, objects such as walls, doors, windows were stored 
as a non-graphical data with the assigned graphics. These systems arranged the information 
logically, but were unable to optimize its usage in a building project. Realizing the advantages 
of the solid modeling tools, the mechanical and manufacturing industry professionals began 
using the information modeling CAD technology. This technology enabled them to extract 
data based on the relationship between model elements. 

In 1997, a group of mechanical CAD technologists began working on a new software for 
the building industry. The Building Information Modeling ( BIM) provided an alternative 
approach to building design, construction and management. This approach, however, 
required a suitable technology to implement and reap its benefi ts. In such a situation the use 
of parametric technology with the Building Information Modeling approach was envisaged 
as an ideal combination. They developed a software that was suitable for creating building 
projects. This led to the development of a software later came to be known as Autodesk Revit 
Building, and has now been changed to Autodesk Revit Architecture. 

Autodesk Revit Architecture is a building design and documentation platform, in which a 
digital building model is created using the parametric elements such as walls, doors, windows, 
and so on. All building elements have inherent relationship with one another, which can be 
tracked, managed, and maintained by the computer. 

 BASIC CONCEPTS AND PRINCIPLES 
Autodesk Revit Architecture enables you to envisage and develop a building model with actual 
3D parametric building elements. It provides a new approach to the architectural thought and 
the implementation process. In a way, it replicates the way architects conceive a building. For 
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example, 2D CAD platforms mostly use lines to represent all elements, as shown in Figure 1-1. 
However, in Autodesk Revit Architecture, you can create a building model using 3D elements 
such as walls, fl oors, doors, and windows, as shown in Figure 1-2.

Using these 3D elements, you can visualize the architectural or interior project with respect 
to its scale, volume, and proportions. This enables you to study design alternatives and 

Figure 1-2  Autodesk Revit Architecture project created using parametric building model
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develop superior quality design solutions. Autodesk Revit Architecture automates routine 
drafting and coordination tasks and assists in reducing errors in documentation. This, in turn, 
saves time, improves the speed of documentation, and lowers the cost for users.

 Understanding the Parametric Building Modeling Technology
A project in Autodesk Revit Architecture is created using the in-built parametric building 
elements. The term parametric refers to the relationship parameters between various building 
elements. Some relationships are made by Autodesk Revit Architecture itself, and others by the 
user. For example, doors, which have an inherent parametric relationship with walls, cannot 
be created without fi rst creating a host wall. A door always moves with the host wall. Similarly, 
fl oors too are parametrically linked to walls. When you move walls, the fl oor extents are also 
modifi ed automatically. Each building element has an in-built bidirectional associativity with 
many other elements in the project. 

A building information model is created using different interdependent parametric building 
elements such as walls, fl oors, roof, ceiling, stairs, ramps, curtain walls, and so on. As they are 
bidirectionally associated elements, any change made in one element is automatically adopted 
by others. The integrated building information model thus created contains all data for a 
project. You can then create project presentation views such as plans, sections, elevations, and so 
on for documentation. As you modify the model while working in certain views, Autodesk Revit 
Architecture’s parametric change engine automatically updates other views. This capability is, 
therefore, the underlying concept in Autodesk Revit Architecture. 

Autodesk Revit Architecture’s parametric change engine enables you to modify design elements at 
any stage of the project development. As changes are made immediately and automatically, it 
saves the time and effort of coordinating them in all other associated views, which, for most 
projects, is an inevitable part of the design process. Autodesk Revit Architecture’s capability to 
coordinate between various aspects of the building design provides immense fl exibility in the 
design and development process along with an error-free documentation. 

Autodesk Revit Architecture also provides a variety of in-built parametric element libraries that 
can be selected and used to create a building model. It also provides you with the fl exibility 
of modifying properties of these elements or create your own parametric elements, based on 
the project requirement.

 Terms used in Autodesk Revit Architecture
Before using Autodesk Revit Architecture, it is important to understand the basic terms used 
for creating a building model. Various terms in Autodesk Revit Architecture such as project, 
level, category, family, type, and instance are described next.

 Autodesk Revit Architecture Project
A project in Autodesk Revit Architecture is similar to an actual architectural or interior project. 
In an actual project, the entire documentation such as drawings, 3D views, specifi cations, 
schedules, cost estimates, and so on are inherently linked and read together. Similarly, in 
Autodesk Revit Architecture, a project not only includes the digital 3D building model but 
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also its parametrically associated documentation. Thus, all components such as the building 
model, its standard views, architectural drawings, and schedules combine together to form a 
complete project. A project fi le contains all project information such as building elements used 
in a project, drawing sheets, schedules, cost estimates, 3D views, renderings, walkthroughs, 
and so on. A project fi le also stores various settings such as environment, lighting, and so on. 
As  data are stored in the same fi le, so it becomes easier for Autodesk Revit Architecture to 
coordinate the entire database.

 Levels in a Building Model
In Autodesk Revit Architecture, a building model is divided into different levels. These levels 
may be understood as infi nite horizontal planes that act as hosts for different elements such 
as roof, fl oor, ceiling, and so on. The defi ned levels in a building model can, in most cases, 
relate to different fl oor levels, or stories of the building project. Each element that you create 
belongs to a particular level. 

 Subdivisions of Elements into Categories and Subcategories
Apart from building elements, an Autodesk Revit Architecture project also contains other 
associated elements such as annotations, imported fi les, links, and so on. These elements have 
been divided into the following categories: 

 Model Category : Consist of various building elements used in creating a building 
                  model such as wall, fl oor, ceiling, roof, door, window, furniture,                             
      stairs, curtain systems, ramps, and so on

 Annotation Category : Consist of annotations such as dimensions, text notes, tags, symbols,  
     and so on

 Datum Category : Consist of datums such as levels, grids, reference planes,   
      and so on

 View Category  : Consist of interactive project views such as fl oor plans,  ceiling     
      plans, elevations, sections, 3D views, renderings, and    
                  walkthroughs

In addition to these four categories, other categories such as Imported, Workset, Filter, and 
Revit Categories can also exist, if the project has imported fi les, enabled worksets, or linked 
Autodesk Revit Architecture projects, respectively.

 Families in Autodesk Revit Architecture
Another powerful concept in Autodesk Revit Architecture is family. A family is described as a 
set of elements of the same category that can be grouped together based on certain common 
parameters or characteristics. Elements of the same family may have different properties, but 
they all have common characteristics. For example, Double Hung is a single window family, 
but it contains different sizes of double hung windows. Family fi les have a .rfa extension. You 
can load additional building component familiy from the libraries provided in Autodesk Revit 
Architecture package. 
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Families are further divided into certain types. Type or family type, as it is called, is a specifi c 
size or style of a family. For example, Double Hung : 36” x 48” is a window type. All uses of 
the same family type in a project have same properties. Family and family types can also be 
used to create new families using the Family Editor. 

Instances are the actual usage of model elements in a building model or annotations in a 
drawing sheet. A family type, created in a new location, is identifi ed as an instance of the 
family type. All instances of the same family type have same properties. Therefore, when you 
modify the properties of a family type, the properties of all its instances also get modifi ed. 
The family categorization of Revit elements is given below:

Model Category :  Wall
Family   :  Basic Wall
Family type  :  Brick on Mtl. Studs
Instance  :  Particular usage of a family type

The hierarchy of building elements in Autodesk Revit Architecture plays an important role 
in providing the fl exibility and ease of managing a change in the building model. Figure 1-3 
shows the hierarchy of categories and families in a typical Autodesk Revit Architecture project. 
The following is another example of the terms described in this section.

 Creating a Building Model Using Parametric Building 
Elements
Another classifi cation of categories of elements followed in Autodesk Revit Architecture is based 
on their usage. Autodesk Revit Architecture uses fi ve classes of element: host, component, 
annotation, view, and datum. Hosts are the element categories that form the basic structure of a 
building model and include model elements such as walls, fl oor, roof, and ceiling. Components 
are the elements that are added to host elements or act as stand-alone elements such as doors, 
windows, and furniture. Annotations are the 2D, view-specifi c elements that add content to 
the project documentation such as dimensions, tags, text notes, and so on. Views represent 
various orientations of a building model such as plans, elevations, sections, 3D views, and so 

Figure 1-3  Hierarchy of Autodesk Revit Architecture categories and families

Autodesk Revit Elements

Model Category Annotation Category Datum Category  View Category
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Floors
Roofs
Ceilings
Doors
Windows
Stairs

Dimensions
Text Notes
Tags
Symbols
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Sections
3D Views
Callout views
Walkthroughs
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on. Datum refers to the reference elements that assist you in creating a building model, which 
include grids, levels, reference planes, and so on.

There is no specifi c methodology available for creating a building model in Autodesk Revit 
Architecture. It provides you with the fl exibility of generating the building geometry based on 
the project requirement, design complexity, and other factors. However, the following steps 
describe a general procedure that may be followed for creating an architectural building models 
using the built-in parametric elements provided in Autodesk Revit Architecture. 

The fi rst step is to create the exterior walls of a building at the predefi ned lowest level (level 1). 
Next, create interior walls at that level and add components to the building model. Then, 
defi ne the upper levels based on the story height of the building. You can also link the control 
height of the walls to the levels and extend the exterior walls to their full height. Next, create 
fl oors and roof using the defi ned levels. Add the site topography to the building model and 
then add site components to complete the building project. You can then create drawing sheets 
with the desired views for its presentation. Autodesk Revit Architecture also provides tools to 
create rendered 3D views and walkthroughs. Figure 1-4 shows an example of a building section 
with various building elements and annotations.

Figure 1-4  Building section showing building elements and levels
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 Visibility/Graphics Overrides, Scale, and Detail Level 
Autodesk Revit Architecture enables you to control the display and graphic representation 
of a single element or the element category of various elements in project views by using the 
visibility and graphics overrides tools. You can select a model category and modify its linetype 
and detail level. This can also be done for various annotation category elements and imported 
fi les. These settings can be done for each project view based on its desired representation. You 
can also hide an element or an element category in a view using the Hide in view and Isolate 
tools. You can override the graphic representation of an element or an element category in 
any view using the Visibility/Graphics tool.   

The scale is another important concept in an Autodesk Revit Architecture project. You can 
set the scale for each project view by selecting it from the available list of standard scales such 
as 1/16”=1’0”, 1/4”=1’0”, 1”=1’0”, 1/2”=1’0”, and so on. As you set a scale, Autodesk Revit 
Architecture automatically sets the detail level appropriate for it. There are three detail levels 
provided in an Autodesk Revit Architecture project: Coarse, Medium, and Fine. You can also 
set the detail level manually for each project view. Each detail level has an associated linetype 
and the detail lines associated with it. The details of annotations such as dimensions, tags, 
and so on are also defi ned by the selected scale.

 Extracting the Project Information
A single integrated building information is used to create and represent a building project. 
You can extract project information from a building model and create area schemes, schedule, 
and cost estimates, and then add them to the project presentation. 

Autodesk Revit Architecture also enables you to export the extracted database to the industry 
standard Open Database Connectivity (ODBC) compliant relational database tables. The use 
of the building information model to extract database information eliminates the error-prone 
method of measuring building spaces individually. 

 Creating an Architectural Drawing Set
After creating the building model, you can easily arrange the project views by plotting them on 
drawing sheets. Drawing sheets can also be organized in a project fi le based on the established 
CAD standards followed by the fi rm. In this manner, the project documentation can easily be 
transformed from the conceptual design stage to the design development stage and fi nally 
to the construction document stage. The project view on a drawing sheet is only a graphical 
representation of the building information model and therefore, any modifi cation in it is 
immediately made in all associated project views, keeping the drawings set always updated.

 Creating an Unusual Building Geometry
Autodesk Revit Architecture also helps you conceptualize a building project in terms of its 
volume, shape, and proportions before working with actual building elements. This is possible 
by using the Massing tool, which enables you to create quick 3D models of buildings and 
conduct volumetric and proportion study on overall masses. It also enables you to visualize 
and create an unusual building geometry. The same massing model can then be converted 
into a building model with individual parametric building elements. It provides continuity in 
the generation of building model right from sketch design to its development.
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 Flexibility of Creating Special Elements
Autodesk Revit Architecture provides a large number of in-built family types of various model 
elements and annotations. Each parametric element has the associated properties that can be 
modifi ed based on the project requirement. 

Autodesk Revit Architecture also enables you to create the elements that are designed specifi cally 
for a particular location. The in-built family editor enables you to create new elements using 
family templates. This provides you with the fl exibility of using in-built elements for creating 
your own elements. For example, using the furniture template, you can create a reception 
desk that is suitable for a particular location in the design. 

 Creating Structural Layouts
Autodesk Revit Architecture’s structural tools enable you to add structural elements to a 
building model. An extensive in-built library of structural elements has been provided in 
Autodesk Revit Architecture. You can add structural columns, beams, walls, braces, and so 
on to the project. Thus, structural consultants can also incorporate their elements in the 
basic architectural building model and check for inconsistency, if any.

 Working on Large Projects
In Autodesk Revit Architecture, you can work on large projects by linking different 
building projects together. For a large project that consists of a number of buildings, you can 
create individual buildings as separate projects and then link all of them into a single base fi le. 
The database recognizes the linked projects and includes them in the project representation 
of the base fi le. 

For example, while working on a large educational institution campus, you can create separate 
project fi les for academic building, administration area, gymnasium, cafeteria, computer centre, 
and so on, and then link them into the base site plan fi le. In this manner, large projects can 
be subdivided and worked upon simultaneously.

 Working in Large Teams and  Coordinating with Consultants
Worksets, in Autodesk Revit Architecture, enable the division of the building model into small 
editable set of elements. The worksets can be assigned to different teams working on the same 
project and then their work can easily be coordinated in the central fi le location. The effort 
required to coordinate, collaborate, and communicate the changes between various worksets 
is taken care of by computer. Various consultants working on a project can be assigned a 
workset with a set of editable elements. They can then incorporate their services and modify 
the associated elements. 

For example, a high rise commercial building project can be divided into different worksets 
with independent teams working on exterior skin, interior walls, building core, toilet details, 
fi nishes, and so on. The structural consultants can be assigned the exterior skin and the core 
workset, in which they can incorporate structural elements. Similarly, the rest of the teams 
can work independently on different worksets. 
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 STARTING Autodesk Revit Architecture 2010
When you turn on your computer, the operating system is automatically loaded. You can start 
Autodesk Revit Architecture by double-clicking on the Autodesk Revit Architecture 2010 
icon on the desktop or from the windows taskbar by choosing the Start button at the lower 
left corner of the screen (default position). Next, choose Programs > Autodesk > Autodesk 
Revit Architecture 2010 > Autodesk Revit Architecture 2010, as shown in Figure 1-5. Note 
that this path is for the Windows Vista operating system

Note
The path for starting Autodesk Revit Architecture depends on the Operating System being 
used.

On doing so, the inactive interface screen with the New Workshop Features dialog box will 
be displayed. Select any of the required radio buttons from the window and choose the OK 
button; the New Workshop Features will be closed and the interface screen will be displayed, 
as shown in Figure 1-6. The screen has two sections: Projects and Families. The Projects 
section allows you to open a new or an existing project and the Families section allows you 
to open a new or existing family.

To open an existing project fi le, choose the Open button from the Projects section; the Open 
dialog box will be displayed. Browse to the respective location in the dialog box and select the 
required fi le. Now, choose the Open button to open the fi le.    

Figure 1-5  Starting Autodesk Revit Architecture 2010 using the taskbar shortcut menu
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To open a new project fi le, choose the New option from the Projects area of the interface; the 
New Project dialog box will be displayed. Make sure that the Project radio button is selected 
in the New Project dialog box and choose the OK button; the project fi le will open and the 
interface screen will be activated.

 USER INTERFACE
In Autodesk Revit Architecture 2010, the user interface has been completely redesigned. 
As compared to Autodesk Revit Architecture 2009, the toolbar, menu bar, and Design Bar 
have been replaced by the ribbon in Autodesk Revit Architecture 2010. The ribbon, contains 
task-based tabs and panels that streamline the architectural workfl ow and optimize the delivery 
time of a project. In Autodesk Revit Architecture 2010, when you select an element in the 
drawing area, the ribbon displays a contextual tab that comprises of tools corresponding to the 
selected element. Autodesk Revit Architecture is similar to many other Microsoft Windows based 
programs. Its main parts are Ribbon, Options Bar, Project browser, Drawing Area, Status 
Bar, and View Control Bar, as shown in Figure 1-7.

Note
In Autodesk Revit Architecture 2010, you cannot switch between the menu-based interface of 
Revit Architecture 2009 and the ribbon-based interface of Autodesk Revit Architecture 2010.

 Invoking Tools 
To perform an operation, you can invoke the required tools by using any one of the following 
two options:

Ribbon: You can invoke all necessary tools  from the ribbon.

Shortcut Keys: Some tools can also be invoked using keys on the keyboard.

Figure 1-6  The interface screen display of Autodesk Revit Architecture 2010
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 Title Bar
The Title bar, docked on the top portion of the user interface, displays the program’s logo, 
program’s name, name of the current project, and the view opened in the viewing area. Project 
1- Floor Plan: Level 1 is the default project and view. 

Ribbon
The ribbon, shown in Figure 1-8, is a new interface that is used to invoke tools. When 
you create or open a fi le, the ribbon is displayed at the top in the screen. It comprises of 
task-based tabs and panels, refer to Figure 1-8, which provides all tools necessary for creating 
a project. The tabs and panels in the ribbon can be customized according to the need of 
the user. This can be done by moving the panels and changing the view states of the ribbon 
(changing the ribbon view state is discussed ahead in this chapter). The ribbon has three types 
of buttons; namely,  general button, drop-down button, and split button. These buttons can 
be used from the panels. 

Figure 1-7   Autodesk Revit Architecture 2010 user interface screen

Figure 1-8   Different components of a ribbon

Tip: Tooltips appear when you rest the cursor over any tool icon in the ribbon. The 
name of the tool appears in the box, assisting you to identify each tool icon. 
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Moving the Panels
In the ribbon, you can move a panel and place 
it anywhere in the screen. To do so, click on the panel 
label in the ribbon, hold the mouse and drag the panel 
to a desired place on the screen. Next, use the tools of the 
moved panel and place the panel back to the ribbon. To 
do so, place the cursor on the moved panel and choose 
the Return Panels to Ribbon button from the upper right 
corner of this panel, as shown in Figure 1-9; the panel will return to the ribbon.
   

Changing the View States of the Ribbon
The ribbon can be displayed in three view states by selecting any of the following three options: 
Show Full Ribbon, Minimize to Panel Tiles, and Minimize to Tabs. To use these options, move 
the cursor and place it over the down arrow on the right of the Manage tab (refer to Figure 
1-10) in the ribbon; the down arrow will be highlighted. Now, right-click on the down arrow; 
a fl yout will be displayed. Place the cursor over the Minimize option in the fl yout; a cascading 
menu will be displayed, as shown in Figure 1-10. On choosing the Show Full Ribbon option 
from the cascading menu, the entire ribbon will be displayed. If you choose the Minimize to 
Panel Tiles option, the ribbon will display the tabs and panel labels. On choosing the Minimize 
to Tabs option, the ribbon  will display only the tabs.

The following table describes various tabs in the ribbon and their functions:
 
  Tab     Description
 
  Home              Contains tools for creating building model 

  Create  This tab is only available in Family Editor. It contains tools that are used
  to create a family 

  Insert   Contains tools to insert or manage secondary fi les such as raster image fi les  
  and CAD fi les 

  Annotate  Contains tools for documenting a  building model such as adding texts and  
  dimensions

  Modify  Contains tools for editing elements and the selected data 

Figure 1-9   Choosing the Return 
Panels to Ribbon button

Figure 1-10   Various options in the cascading menu for changing the view state of the ribbon 
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 Massing & Site  Contains tools for modeling and modifying conceptual mass and site 
      elements

  Collaborate     Contains tools for collaborating the project with other team members   
      (internal and external).  

  View          Contains tools used for managing and modifying the current view and also  for 
       switching views.

  Manage     Contains tools for specifying the project and system parameters, and   
                               settings. 

Contextual Tabs in the Ribbon
These tabs are displayed when you use certain tools or select elements. These tabs contain a 
set of tools that relates only to the context of that tool or element.

For example, when you invoke the Window tool, the Place Window contextual tab is displayed. 
This tab shows three panels: Selection, Element, and Model. The Selection panel contains 
the Modify tool. The Element panel consists of the Element Properties button and the 
Type Selector (Change Element Type) drop-down list. The Model panel consists of necessary 
tools that are used to load model families or create the model of a window in a drawing. The 
contextual ribbon tab closes when the tool invoked to displayed this tab is closed. 

Application Frame
The application frame helps you manage projects in Autodesk Revit Architecture. It consists 
of Application button, Application Menu, Quick Access Toolbar, InfoCenter, and Status 
Bar. These are discussed next.

Application Button
The Application button is displayed at the top-left corner of the Revit interface. This 
button is used to display Application Menu as well as close it.  

Application Menu  
The Application Menu contains the tools that provide access to many common fi le actions 
such as Open, Close, and Save. Click the down arrow on the Application button to display 
tools. Alternatively, press ALT+F to display tools in the Application Menu, as shown in 
Figure 1-11.  

Quick Access Toolbar
The Quick Access Toolbar, as shown in Figure 1-12, contains options to undo and redo 
changes, open and save a fi le, create a new fi le, and so on. 
   
By default, the Quick Access Toolbar contains the following options: New, Open, Save, Redo, 
Undo, Modify, and 3D View. You can customize the display of Quick Access Toolbar by 
adding more tools and removing unwanted tools. To add a button from the panel of the ribbon 
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to Quick Access Toolbar, place the cursor over the button; the button will be highlighted. 
Next, right-click; a fl yout will be displayed. Choose Add Quick Access Toolbar from the fl yout 
displayed; the highlighted button will be added to Quick Access Toolbar.   

InfoCenter
You can use InfoCenter to search information related to Revit Architecture (Help), display 
the Subscription Center panel for subscription services and product updates, and display the 
Favorites panel to access saved topics. Figure 1-13 displays various tools in InfoCenter.

Figure 1-11  The Application Menu

Figure 1-12  The Quick Access Toolbar 
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View Control Bar
The View Control Bar is located at the lower left corner of the drawing window, as shown in 
Figure 1-14. It can be used to access various view-related tools. The Scale button shows the 
scale of the current view. You can choose this button to display a fl yout that contains standard 
drawing scales. From this fl yout, you can then select the scale for the current view. The Detail 
Level button is used to set the detail level of a view. You can select the required detail level 
as: Coarse, Medium, and Fine. Similarly, the Model Graphics Style button enables you to 
set the display style. The options for setting the display style are: Wireframe, Hidden Line, 
Shading, and Shading with Edges.

Status Bar
The Status Bar is located at the bottom of the interface screen. When the cursor is placed 
over an element or component, the Status Bar displays the name of the family and type of 
the corresponding element or components. It also displays prompts and messages to help 
you use the selected tools.

 Options Bar
The Options Bar provides information about the common parameters of the component type 
and the options for creating or editing it. The Options Bar changes its appearance based on 
the type of component selected or being created. You can also modify the properties of the 
component by entering a new value in the edit box for the corresponding parameter in the 
Options Bar. For example, the Options Bar for the Wall tool displays various options to create 
a wall, as shown in Figure 1-15.

Figure 1-13  The InfoCenter

Figure 1-14  The  View Control Bar

Figure 1-15  The Options Bar with different options to create a wall
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Type Selector (Change Element Type)
The Type Selector drop-down list is located in the Element panel of the tab for the currently 
invoked tool. For example, on invoking the Wall tool, the Place Wall tab will be displayed. 
From the Type Selector drop-down list in the Element panel of this tab, you can select 
the required type of the wall. The Type Selector drop-down list has been referred as the 
Change Element Type drop-down list from Chapter 2 to Chapter 5 of this textbook. 

The content in the Type Selector drop-down list keeps on changing, depending upon 
the current function of the tool or the elements selected. When you place an element or a 
component in a drawing, you can use the Type Selector drop-down list to specify the type of 
element or component. You can also use this drop-down list to change the existing type of a 
selected element to a different type.

Drawing Area
The Drawing Area is the actual modeling area, where you create and view the building model. It 
covers the major portion of the interface screen. You can draw various building components in 
this area using the pointing device. The position of the pointing device is represented by the 
cursor. The Drawing Area also has the standard Microsoft Windows functions and buttons such 
as close, minimize, maximize, scroll bar, and so on. These buttons have the same function as 
that of the other Microsoft Windows-based program.

 Project browser
The Project browser is located below the ribbon. It displays project 
views, schedules, sheets, families, and groups in a logical, tree-like 
structure, as shown in Figure 1-16 and helps you to open and manage 
them. To open a view, double-click on the name of the view, or drag 
and drop the view in the Drawing Area. You can close the Project 
browser or dock it anywhere in the Drawing Area.  

Note
If the Project browser is not displayed on the screen, choose the 
View tab from the ribbon and then choose Windows > User 
Interface. Next, select the Project browser check box from the 
fl yout displayed.

The Project browser can be organized to group the views and sheets 
based on the project requirement. For example, while working on a large project with a number 
of sheets, you can organize the Project browser to view and access specifi c sheets.  

Note
In the Project browser, you can expand or contract the view listing by selecting the ‘+’ or ‘-’ 
sign, respectively. The current view in the drawing window is highlighted in bold letters. The 
default project fi le has a set of preloaded views.

Figure 1-16  The Project 
browser
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  Keyboard  Accelerators
In Autodesk Revit Architecture, accelerator keys have been assigned to some of the frequently 
used tools. These keys are shortcuts that you can type through the keyboard to invoke the 
corresponding tool. Accelerator keys corresponding to a tool appear as a tooltip when you
move the cursor over the tool.

DIALOG BOXES
Certain Autodesk Revit Architecture tools, when invoked, display a dialog box. The dialog 
box is a convenient method of accessing and modifying parameters related to that tool. For 
example, when you choose Save As > Project from Application Menu, the Save As dialog 
box is displayed, as shown in Figure 1-17. A dialog box consists of various parts such as the 
dialog label, radio buttons, text or edit boxes, check boxes, slider bars, image box, and tool 
buttons, which are similar to other windows-based  programs. Some dialog boxes contain 
the [...] button, which displays another related dialog box. There are certain buttons such as 
OK, Cancel, and Help, which appear at the bottom of most of the dialog boxes. The names 
of the buttons imply their respective functions. The button with a dark border is the default 
button.

Figure 1-17  The  Save As dialog box

Tip: As you become accustomed to using Autodesk Revit Architecture, you will fi nd 
these Keyboard Accelerators quite useful because they save the effort of browsing 
through the menus.
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 MULTIPLE DOCUMENT ENVIRONMENT
The multiple document environment feature allows you to open more than one project at a 
time in a single Autodesk Revit Architecture session. This is very useful when you want to work 
on different projects simultaneously and make changes with reference to each other. 

Sometimes, you may need to incorporate certain features from one project into the other. 
With the help of multiple document environment, you can open multiple projects and then 
use the Cut, Copy and Paste tools from the Clipboard panel of the Modify (type of element) 
tab to transfer the required components from one project to another. These editing tools can 
also be invoked by using the CTRL+C and CTRL+V keyboard shortcuts.

To access the opened projects, choose Windows > Switch Windows from the View tab; a fl yout 
will be displayed showing the name of different project fi les opened, as shown in Figure 1-18. 
Like other Microsoft Windows-based programs, you can select and view the opened projects 
using the Cascade and Tile options from the Windows panel of the View tab. The cascaded view 
of projects is shown in Figure 1-19.

 INTEROPERABILITY OF Autodesk Revit Architecture
The models or geometries created in Revit Architecture can easily be exported to AutoCAD 
based programs, such as 3ds Max and Max Design, in the DWG fi le format. This enables you 
to visualize and create photorealistic exterior and interior renderings for your project designs. 
You can also transfer drawings from Revit Architecture to Google SketchUp to visualize your 
projects in a better way. Revit Architecture 2010 comes with Google Earth plugin for publishing 
Revit models to it.

Revit Architecture 2010 follows a wide range of industry standards and supports various CAD 
fi le formats such as DWF, DGN, DWG, DGN, IFC, SKP, and SAT. For image fi les, it supports 
JPG, TIFF, BMP, PNG, AVI, PAN, IVR, and TGA fi le formats. Besides these, the formats 
that are supported by Revit Architecture include ODBC, HTML, TXT, gbXML, XLS, and 
MDB. Revit Architecture is compatible with any CAD system that supports the DWG, DXF, or 
DGN fi le format. Revit Architecture can import the models and geometries as ACIS solids. 
This enables designers to import models from AutoCAD Architecture and AutoCAD MEP 
(Mechanical, Electrical, and Plumbing) software and to link and import 3D information to Revit 
Architecture. This feature makes Autodesk Revit Architecture 2010 an effi cient, user-friendly, 
and compatible software. 

Figure 1-18  Choosing the Switch 
Windows option

Tip: You can open a number of views at the same time. The Tile and Cascade 
options in the Windows panel of the View tab are used to arrange the views.
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 BUILDING INFORMATION MODELING AND Autodesk 
Revit Architecture 2010
Building Information Modeling (BIM) is defi ned as a design technology that involves the 
creation and use of coordinated, internally consistent, and computable information about 
a building project in design and construction. BIM covers spatial relationships, geographic 
information, quantities, and properties of building components. Using this technology, you can 
demonstrate the entire life cycle of a building project starting from the process of construction, 
facility operation, and  information about quantities and shared properties of elements. BIM 
enables the circulation of virtual information model from the design team to contractors 
and then to the owner thereby adding changes and their knowledge to update the model at 
each stage of transfer. The ability to keep information up-to-date and make it available in 
an integrated digital environment enables the architects, owners, builders, and engineers to 
have clear vision of the project before the commencement of actual construction. It enables 
them to make better and faster decisions as well as to improve the quality and profi tability of 
projects. Autodesk Revit Architecture 2010 is a specially designed platform based on BIM. 
Revit Architecture 2010 is the best example of the BIM technology. Revit Architecture’s 
parametric model represents a building as an integrated database of coordinated information. 
In Revit, change anywhere is change everywhere. Any change made in your project at any 
stage is refl ected in the entire project, and also, due to the parametric behavior of elements, 
the project is updated automatically according to the changes made anywhere in the project. 
Also, the integration of Revit Architecture with the available in-built commercial tools such 
as solar studies, material takeoffs, and so on greatly simplifi es the project design and reduces 
the time consumed by these analyses, thereby enabling faster decision making. 

Figure 1-19  The cascaded view of the project
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 Autodesk Revit Architecture HELP
Autodesk Revit Architecture provides help to easily understand various tools and methods 
used in it. To access the help feature, click on the down arrow on the right of the Help button 
in InfoCenter; a drop-down  menu containing help options will be displayed, as shown in 
Figure 1-20. The help options are discussed next.

Autodesk Revit Architecture 2010 Help                 
On choosing the Help button from the InfoCenter, the Revit Architecture Help dialog box 
will be displayed, as shown in Figure 1-21. You can access help on various tools and other 
aspects of the program in a number of ways by using the F1 key. The four tabs provided in 
this dialog box to facilitate your search are discussed next.

 Contents Tab
The Contents tab is chosen by default and displays the help topics by titles, pertaining to 
different sections of Autodesk Revit Architecture such as Using Help, Start a New  Project, 
and so on, refer to Figure 1-21. To select a title, click on the corresponding book icon or 
choose the ‘+’ sign on the left; the icon will become an open book with a ‘-’ sign and a list 
of topics associated with that category will be displayed. Click on the ‘+’ sign to expand the 
subheadings, until you reach the help topic that has a question mark ‘?’ displayed in it. Next, 
select the topic to display the information about it in the display window present on the right 
of the dialog box.

Figure 1-20  A drop-down menu displaying help options  

Tip: You can also search for a topic using wildcards (* , ? ) and boolean 
operators (AND, OR, NEAR, NOT). These boolean operators can be accessed by 
clicking on the right arrow next to the edit box.

Tip: The Help and ‘?’ buttons can be used to provide assistance related to the 
contents of the dialog box.
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 Index Tab
The Index tab displays the complete index of tools and options of Autodesk Revit Architecture 
in an alphabetical order. To search for information about a tool or an option, type the name 
of the tool or its related word in the edit box. As you type the letters for the search in the edit 
box, the listing in the list area keeps on changing, displaying possible topics with those initials. 
If Autodesk Revit Architecture fi nds any reference to the word entered, it will automatically 
be highlighted in the list area. You can choose the Display button below the list area to view 
information on a specifi c subject. 

 Search Tab
The Search tab is used to access the help fi les related to certain keywords. Three check 
boxes: Search previous results, Match similar words, and Search titles only have been 
provided in this tab to narrow down the search to a specifi c topic. On typing the keyword in 
the edit box, you can select one or more of these options and then choose the List Topics 
button. A list of help fi les related to the keyword entered appears. Choose the topic from the 
Select topic list box and then choose the Display button to view its help. The listed topics for 
the typed word appear with ranks in the Select topic list box. A search is ranked according to 
the number of matching words found in that topic.

 Favorites Tab
Using the Favorites tab, you can create a list of favorite topics that you need to access frequently. 
The Current Topic edit box displays the topic that you last viewed in any other tab of Autodesk 
Revit Architecture Help. Use the Add button to include that title in your list of favorite topics. 
Similarly, you can add other topics to this list and create an information database. You can 
remove a topic from the list by using the Remove button. You can also choose the Display 
button to view the help fi les related to each topic.

Figure 1-21  The Revit Architecture Help dialog box  
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Note
The list of favorite topics created by you is saved at the time of quitting the Autodesk Revit 
Architecture session and becomes available for your reference in future sessions.

 Context Sensitive Help
If you need help specifi c to a selected tool or a dialog box, Autodesk Revit Architecture 
provides several options to access the relevant information. Many dialog boxes contain the 
Help button and can be used to view help on that dialog box and related topics. If the Help 
button is not available, you can press the F1 key, while the dialog box is open, to access the 
related information. 

To inquire about a tool button, place the cursor over the button of a tool, a Help message 
box will be displayed. Now, you can press the F1 key to view more help contents pertaining 
to the button, in a separate window. 

To turn off the Help tooltips for buttons, choose Application Menu > Options; the Options 
dialog box will be displayed. In the General tab of this dialog box, select the None option 
from the Tooltip assistance drop-down list in the Notifi cations area. Now, choose OK to close 
the Options dialog box.      

User Interface Overview
To take a quick lesson on how Autodesk Revit Architecture works, choose Help > User Interface 
Overview from the InfoCenter; the Revit Architecture User Interface Overview window 
will be displayed. In this window, choose the A4 or Letter button placed at the lower right 
corner of the window; a PDF fi le will open. This fi le that takes you through the user interface 
of Autodesk Revit Architecture 2010 that will let you understand the placement of basic tools 
in Autodesk Revit Architecture. 

Tutorials
The imperial tutorial exercises and datasets are available on the Autodesk 
website. To access them, you need to download the tutorial files and datasets 
from the website. To do so, choose Help > Tutorials from InfoCenter. The Revit 
Architecture 2010 Imperial Tutorial window will be displayed, as shown in Figure 1-22. 
Follow the instructions displayed in the window to access the Revit tutorials and datasets. 
Once you have downloaded the tutorials and datasets from the website, the Revit Architecture 
2010 Imperial Tutorial window will be displayed every time you access the tutorials. 
Revit Architecture 2010 Imperial Tutorial window has a link Developing Your Designs, 
Documenting Your Projects, and so on. It has three tabs: Context,  Search, and Favorites to 
help you access the relevant information. These tabs have functions similar to the tabs in the  
Revit Architecture Help dialog box.
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Figure 1-22  The Revit Architecture 2010 Imperial Tutorial dialog box  



Chapter 2

Getting Started with 
Revit Architecture 

After completing this chapter, you will be able to:
• Start a new project.
• Set units of various measurement parameters for a project.
• Understand the concept of snaps, dimensions, and object snaps.
• Save a project.
• Modify parameters and settings of a project.   
• Close a project and exit Revit Architecture.
• Open an existing project.
• Explore the building model using viewing tools.
• Use the Navigation tools.

Learning Objectives
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In this chapter, as you start learning to create a new building project, you will also learn the 
methods of creating the initial setups such as units, snaps, and others.

 STARTING A NEW PROJECT

In  Autodesk Revit Architecture, a project is considered as a single database that contains all 
information related to building design. As such, the three-dimensional models drawn using 
this software are called building information models. Starting from geometry to construction 
data, each project fi le contains the complete information of the building design 

In Revit Architecture, whenever you start a new project, the new project fi le uses the default 
settings defi ned in a project template, called default.rte. To start a new project, choose the 
Application button from Application Menu, as shown in Figure 2-1. From Application Menu, 
choose New > Project; the New Project dialog box will be displayed, as shown in Figure 2-2. 
Using this dialog box, you can select an existing .rte template fi le format to use it for the new 
project.

 

Shortcut Key:       CTRL+N
Application Menu:  New > Project 

Figure 2-1  Choosing the Project option from the cascading menu 

Figure 2-2  The  New Project dialog box
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A template fi le has various project parameters such as units and views, already saved in it. 
On using it, the new project will adopt the same parameters as the template fi le. The default 
template fi le is default.rte. The difference between a template and a project fi le is that the 
template fi les have a .rte extension whereas the project fi les have a .rvt extension. You can 
either select any of the template fi les provided in Revit Architecture or create your own fi le. 
Any project fi le can be saved as a template fi le. You can select the fi le to be used as a template 
by clicking on the Browse button in the New Project dialog box. To create a new project, select 
the Project radio button and to create a template, select the Project template radio button.

Note
If you select the None and Project radio buttons from the Template fi le and Create New areas, 
respectively, a new project fi le will be created without a template fi le, but with the default settings 
of Autodesk Revit Architecture.  

 SETTING UNITS

Units are the important parameters of a project. While installing the program, Revit 
Architecture prompts you to set the default unit as Imperial (feet and inches) or Metric (meter). 
The default selection of unit helps you start your project with a specifi c type of unit as per the 
conventions followed in the industry. To set units, choose Project Settings > Project Units 
from the Manage tab of the ribbon; the Project Units dialog box will be displayed, as shown 
in Figure 2-3. Project units are grouped into three disciplines: Common, Structural, and 
Electrical. Each discipline has a set of measurement parameters. You can select any of these 
disciplines from the Discipline drop-down list of this dialog box. In this drop-down list, the 
Common option is selected by default. As a result, various measurement parameters such as 
Length, Area, Volume, Angle, Slope, and Currency will be displayed in the Project Units 
dialog box. The Format column in the dialog box displays the current unit format for the 
corresponding parameter in the Units column. You can preview and select the possible digit 
grouping and decimal separators from the Decimal symbol/digit grouping drop-down list, 
which is at the lower left corner of the dialog box, refer to Figure 2-3. 

 Length Unit Setting
In Autodesk Revit Architecture, you can assign a different unit for the measurement of 
length  in the Project Units dialog box. To do so, click in the Format column in the Length 
row; the Format dialog box will be displayed. This dialog box displays the units of length 
and its settings, as shown in Figure 2-4. You can select the desired unit from the Units 
drop-down list in the dialog box. The options that can be selected from the drop-down list 
are  Decimal feet, Feet and fractional inches, Decimal inches, Fractional inches, Meters, 
Centimeters, Millimeters, and Meters and Centimeters. After selecting the desired unit, 
you can specify the rounding value for the selected unit. To do so, select the desired option 
from the Rounding drop-down list in the Format dialog box. Note that by, default, the 
Rounding increment edit box in the Format dialog box is inactive. To make it active, select 
the Decimal feet or Decimal inches option from the Units drop-down list and then select 
Custom from the Rounding drop-down list. The default value in the Rounding edit box is 

Ribbon:  Manage > Project Settings > Project Units        
Shortcut Key:  UN
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Figure 2-3  The  Project Units dialog box

Figure 2-4  The Format dialog box

1. You can change the default value by entering a value in this edit box. Similarly, the Units 
symbol drop-down list will be inactive for the Feet and fractional inches, Fractional inches, 
and Meters and Centimeters options in the Units drop-down list. You can select the desired 
option from the Units symbol drop-down list to specify the measurement symbol that you 
want to add along with the unit of length. For example, to use the symbol ‘m’ after all metric 
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length measurements, you can select m from the drop-down list as the measurement symbol. 
In the Format dialog box, you can select the Suppress spaces check box to remove all spaces 
around the dash from the length strings. For example, you can remove spaces in the dash when a 
length string is expressed in feet and fractional inches to denote a particular measurement.

 Area Unit Setting
In the Project Units dialog box, you can assign a  unit for measuring area. To do so, click 
in the Format  column for the Area parameter; the Format dialog box will be displayed.  In 
this dialog  box, you can set the unit for measuring area from the Units drop-down list that 
contains various options for units of area such as  Square Feet, Square Meters, Acres, and so on. 
The Square feet option is selected by default in this drop-down list, if you select Imperial units 
at the time of installing Revit Architecture. The settings for rounding, rounding increment, and 
unit symbol for the area units can be made from their respective drop-down lists and edit boxes.

 Volume and Angle Unit Settings
The units for volume and angle can also be set similar to that of the length and area. You 
can set the unit for the volume measurement by selecting any of the options such as Cubic 
yards, Cubic feet, Cubic meters, Liters, and US gallons from the Units drop-down list in the 
Format dialog box of the Volume parameter. Similarly, you can specify the unit for the angle 
measurement by selecting the required option from the Units drop-down list in the Format 
dialog box of the Angle parameter. You can select either Decimal degrees or Degrees minutes 
seconds from the Units drop-down list for specifying the unit for the volume measurement.

 Slope Setting
To specify the unit for the slope measurement, click in the Format column for the Slope 
parameter; the Format dialog box will be displayed. In this dialog box, you can specify the 
desired unit settings by selecting the required option from the Units drop-down list. The Units 
drop-down list contains various options such as Ratio : 12, Ratio :10, Rise / 12”, Rise 1 / 
1’-0”, Rise / 1000mm, Decimal degrees, and Percentage as the unit of the slope measurement. 
The default option for the Imperial unit setting in the drop-down list is Decimal degrees.

Currency Setting
In Revit Architecture 2010, you can set  the unit for currency as well. You can select different 
types of currency symbols from the Unit symbol drop-down list in the Format dialog box of 
the Currency parameter.

Tip: While selecting a rounding value from the Rounding drop-down list in the 
Format dialog box, you should consider the extent of detailing that may be required 
for the project and then select it. For projects that requires too much detailing, a 
lower rounding value may be set. This parameter, however, can be modifi ed at any 
time during the project development.

Tip: As soon as you change the units and choose the OK button to close the Format 
dialog box, the numbers and units shown for each measurement parameter in the 
Project Units dialog box are modifi ed to the new settings. You can modify their 
settings and format any time during the project.
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Note 
You can only format  the display of units as they are represented on the screen or printout using 
the Project Units dialog box. The actual values for these units in the project may be different. 
For example, if you set the wall length rounding to the nearest 1’, the wall may show this rounded 
value, but the actual length of the wall might be in fractional feet.

 SNAP SETTINGS

The Snaps tool is one of the most productive tools available while creating and editing elements 
in a building model. This tool represents the ability of the cursor to snap or jump to the preset 
increments or specifi c object properties of various elements such as endpoint, midpoint, and 
so on. To invoke the Snaps tool, choose Project Settings > Settings >  Snaps from the Manage 
tab of the ribbon; the Snaps dialog box will be displayed, as shown in Figure 2-5. This dialog 
box has three areas, Dimension Snaps, Object Snaps, and Temporary. These area are 
discussed next.

Note
The settings in this dialog box apply to all the projects opened in the session and are not saved 
with a particular project. 

 Dimension Snaps 
Revit Architecture enables you to set increments for adding various elements of the project. 
The dimension snap is the increment, in which the cursor moves while creating components. 
Revit Architecture automatically adjusts the dimension snap values as the views are zoomed. 
The default settings are: 4’; 0’6”;0’1”; 0’1/4”. Note that every incremental value is separated 
by a semicolon (;). You can also set the increments by typing the values that are separated by a 
semicolon. For example, to create an interior layout plan in which the length of the partitions 
is in 5’ modules, counter top width is 2’ and the thickness of partitions is 4”, you can enter 
the values for the dimension snaps as 5’; 2’;4”. This will enable the cursor to move in these 
increments and help create the layout with relative ease.

The angular dimension snap increments can be set in a similar manner by entering the  values 
in the Angular dimension snap increments edit box, if desired. This parameter is quite useful 
for projects that have a radial geometry.

 Object Snaps 
Object Snaps, a useful tool for creating and editing elements in Revit Architecture, refers to 
the cursor’s ability to snap to geometric points on an element such as endpoints, midpoint, 
perpendicular, and so on. The advantage is that you do not need to specify the exact point. 
When enabled, the appropriate object snap is displayed as soon as the cursor is close to 
an element. For example, it is virtually impossible to pick the exact endpoint to start a wall 
from an endpoint of an already drawn wall. But when you enable the endpoint object snap, 

Ribbon:  Manage > Project Settings > Settings > Snaps

Tip: The Dimension Snaps parameter should be set based on the scale and the 
amount of detailing required for the project. You may set smaller increments for 
working on a detail or a small portion of a building.
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the cursor automatically jumps or snaps to the endpoint of this wall. This helps to start the 
new wall from the endpoint. This, besides making the drawing accurate, later helps in adding 
dimensions to the project.

Note
The object snaps tool works only with the objects that are visible on the screen. A tooltip, with the 
same name as the object snap, is also displayed when you bring the cursor close to snap point.
  

Various object snaps modes are available in Revit Architecture such as Endpoints, Midpoints, 
Nearest, Work Plane Grid, Quadrants, Intersections, Centers, Perpendicular, Tangents, 
Points, and Snap to Remote Objects.

The use of each object snap corresponds to its respective name. The  Work Plane Grid snap  
option enables you to snap to a point on a reference plane already defi ned in the model. For 
example, you can place a furniture component exactly on the fl oor by snapping to the fl oor 

Figure 2-5  The Snaps dialog box
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level reference plane. You can also snap to the object that is closest to the cursor using the 
Snap to Remote Objects option.

Each object snap mode has a geometrical shaped marker to identify it from the other object 
snaps. For example, the endpoint object snap is indicated by a square, midpoint by a triangle, 
nearest by a cross, and so on. To use an object snap mode, move the cursor over the object. 
You will notice a marker that appears as you move it close to the snap point. To select the 
appropriate snap point, click when the corresponding marker or tooltip is displayed. 

In Revit Architecture, all the enabled object snaps work simultaneously. You can turn off all 
the snap options including the dimension snaps and object snaps by checking the Snaps Off 
check box located at the top of the Snaps dialog box. Alternatively, you can type SO on the 
keyboard to turn them off and on while using a tool. The Check All and Check None buttons 
can be used to enable or disable the object snaps, respectively.

 Temporary Overrides
The Temporary Overrides options provide you the alternative of overriding snaps setting 
for a single use only. For example, if you have not selected the Endpoints object snap in the 
Snaps dialog box and you want to use this option while working with a tool, you need not 
open the Snaps dialog box and set this option. Instead, you can type the shortcut, SE in this 
case, to temporarily activate the endpoint object snap. Once you have used this object snap 
option, snapping to the endpoint is automatically turned off.

You can toggle between various object snap options available at the same location using the 
TAB key on the keyboard. Hold down the SHIFT key to create the elements vertically or 
horizontally. This restricts the movement of the cursor in the orthogonal directions only. Once 
you release the SHIFT key, the cursor resumes its movement in all directions. You can select 
the Snaps Off check box to disable all types of snapping.

 SAVING A PROJECT

You must save your work before closing a project or exiting a Revit Architecture session. You 
have the option of saving the project fi le in a permanent storage device, which may be a hard 
disk or a removable disk such as a CD, fl oppy or USB. Also, you must save your work at regular 
intervals to avoid loss due to any error in the computer’s hardware or software. 

Using the  Save As Tool 
In Autodesk Revit Architecture 2010, you can save your project fi le to the desired location. To do 
so, click the Application button and then choose Save As > Project  from the Application Menu; 

Application Menu:  Save As > Project    
Shortcut key:   CTRL+S                 

Tip: The Snap tool is frequently used, not only while creating various building 
elements but also while editing and placing them. By using this feature effi ciently, 
you can improve the performance and accuracy of your project besides making 
modeling much simpler.
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the Save As dialog box will be displayed, as shown in Figure 2-6. Alternatively, you can save 
the project fi le by choosing the Save button from the Quick Access Toolbar.  

In the Save As dialog box, the Save in drop-down list displays the current drive and path in 
which the project fi le will be saved. The list box below the Save in drop-down list shows all 
folders available in the current directory. The File name edit box can be used to enter the 
name of the fi le to be assigned to the project. The Places List area in the left of the Save As 
dialog box contains shortcuts for the folders that are frequently used. 

 Using the Options Button
You can use different fi le saving features by choosing the Options button from the Save As 
dialog box. On choosing this button, the File Save Options dialog box will be displayed, as 
shown in Figure 2-7. Using the Maximum backups edit box from this dialog box, you can 
specify the maximum number of backup fi les that you need to store for the project. In Autodesk 
Revit Architecture, the non-workshared projects have three backup fi les and the workshared 
projects have twenty backup fi les, by default. The options in the Preview area enable you to 
specify the image to be used as the preview of the project fi le. This image is used at the time 
of opening a project fi le. You can specify the view of the model to be used as a preview image 
from the Source drop-down list in the Preview area of the File Save Options dialog box.

Tip: The selection of large number of backup fi les for storing may use a lot of 
resources on the hard disk.  

The Active view/sheet is the default option for previewing a project fi le. For example, to make 
the Floor Plan: Level 1 the preview image, select it from the drop-down list. Whenever you 
select this project fi le, the preview will always show the Floor Plan: Level 1, irrespective of 
the last active view. 

Figure 2-6  The Save As dialog box
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Select the Regenerate if view/sheet is not up-to-date check box to see the preview with the 
latest modifi cations. Selecting this check box will update the preview image on closing the 
project fi le.  

Note
Revit Architecture updates the preview image continuously. Therefore, selecting the Regenerate 
if view/sheet is not up-to-date check box can consume considerable resources.

Using the  Save Tool

Once the project is saved using the Save As tool, you do not need to re-enter the fi le 
parameters to save it again. To save a project to the hard disk, click the Application 
button and then choose the Save option from the Application Menu, as shown in 

Figure 2-8. While saving the project for the fi rst time, the Save As dialog box is displayed, 
even if you invoke the Save tool.

Alternatively, you can save your project by choosing the Save button from the Quick 
Access Toolbar. As you save your project fi le, Revit Architecture updates it automatically 
without prompting you to re-enter the fi le name and path. 

Application menu:  Save 
Shortcut Key:   CTRL+S

Tip: The Preview image acts as a thumbnail to identify a project fi le. You must 
select a view that will help you identify the project fi le easily. 

Figure 2-7  The File Save Options dialog box 
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CONFIGURING GLOBAL SETTINGS
In Autodesk Revit Architecture, you can confi gure global settings by using the Options dialog 
box. This dialog box can be invoked by choosing the Options button from the Application 
menu. The Options dialog box, as shown in Figure 2-9, contains eight tabs: General, Graphics, 
File Locations, Rendering, Spelling, SteeringWheels, ViewCube, and Macros. The options 
of these tabs are discussed next.  

Figure 2-8  Accessing the Save tool from
Application Menu

Figure 2-9  Setting fi le options using the Options dialog box
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 General Tab
The General tab is the default tab and contains four areas, Notifi cations, Username,   Journal 
File Cleanup, and Display. These areas are discussed next.

 Setting Notifi cations
Revit Architecture provides you the option of setting reminders to save work at regular 
intervals. You can set the time interval at which Revit Architecture will remind you to save the 
project fi le. The default value for the Save Reminder interval parameter is 30 minutes. You 
can specify the time interval by clicking on the down-arrow key and selecting the interval from 
the drop-down list. If you do not want a reminder, you can select the No reminders option 
from the drop-down list. Similarly, you can set the value for the Synchronize with Central 
reminder interval parameter.

The  Tooltip assistance refers to a tooltip that is displayed with the cursor when it is close to a 
tool, snap, or an element. It can be set to the required level by selecting the appropriate option 
from the Tooltip assistance drop-down list. Normal is the default option that is selected in 
this drop-down list. Note that the tooltip will appear more frequently in your drawing if you 
select High in the Tooltip assistance drop-down list.  

Setting the Username 
In Autodesk Revit Architecture you can create a unique identifi cation for a particular session. 
To do so enter a name in the edit box that is displayed in the Username area of the General 
tab. The name that you will enter in this edit box will be used for editing permissions in a 
multi-user Revit Architecture environment.

Note
When you run Autodesk Revit Architecture in your system for the fi rst time , you will notice that 
the Windows login name is displayed as the default username in the edit box in the Username 
area. 

Setting the Journal File Cleanup
Journal fi les are the text fi les that are used to resolve technical problems that may occur 
during the Revit Architecture session and they record every step during the session. Whenever  
you encounter any technical problem with the software, you can run this fi le to detect the 
problem as well as recover the lost fi les or steps that had caused the problem. In Autodesk 
Revit Architecture 2010, these fi les are saved in the following default location: C:\Program 
Files\Autodesk Revit Architecture 2010\Journals. These fi les are saved each time you close the 
Revit Architecture session. As such the quantity of these fi les keeps on increasing until you 
remove these fi les from their location. To retain certain fi les and clean others, you can use the 
Journal File Cleanup area in the General tab of the Options dialog box. This area contains 
two spinners: When number of journal exceeds and Delete journals older than (days). You 
can set the required values in these spinners to retain the fi les that are recently created. For 
example, if you need to delete journal fi les if their number exceeds 15 and if they were created 
before 30 days. Then, in such a situation, set the value in the When number of journal exceeds 
spinner to 15 and the value in the Delete journals older than (days) spinner to 30. 
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Setting the Display of the User Interface 
In the Display area of the General tab, the Active theme drop-down list is available. From 
this drop-down list, you can select two options: Dark and Light. On selecting any of these 
options, the display of  Autodesk Revit Architecture user interface will change. 

Graphics Tab
The Graphics tab enables you to confi gure the display card of your computer to improve 
the performance of the display. You can also use this tab to assign colors for the selection, 
highlights and alerts, and enable anti-aliasing for 3D views. In the Graphics Mode area of 
this tab, select the Use Hardware Acceleration check box to enable hardware accelerators. 
On doing so, the large models in your project will be displayed faster on refreshing the views.  
In addition, it will help you speed up the process of switching between the windows of views 
and the creation and modifi cation of annotations in your project.   

In the Colors area of the Graphics tab, select the Invert background color check box to 
toggle the color of the background and elements. The Selection color parameter refers to a 
color that an element acquires when it is selected. The default color is RGB  059-115-255. To 
use any other color, click the button on the right of the Selection color parameter and select 
the desired color from the Color dialog box. Revit Architecture uses the Alert Color button 
to highlight elements when an error occurs.

 File Locations Tab
By using the File Locations tab, you can set the path for various fi les and directories that 
are accessed frequently, as shown in Figure 2-10. The path for these fi les is set at the time of 
installing Revit Architecture, but you can modify the location by choosing the corresponding 
Browse button and specifying a new path. The default template fi le location can be changed, 
in case you wish to use a custom made template fi le for your projects. Revit Architecture uses 
the default path for user fi les for saving or opening a project. You can also specify the default 
path for family template fi les using the corresponding Browse button.

Figure 2-10  The File Locations tab of the Options dialog box
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 Rendering Tab
Autodesk Revit Architecture 2010 uses the mental ray rendering engine for its rendering 
process. The mental ray has its own library, named Render Appearance Library. This library 
stores information about render appearances for materials, default RPC contents in the 
software, and other information relevant to the rendering process. The Render Appearance 
Library is a read-only library and is loaded into the following default location while installing 
the Revit Architecture software: C:\Program Files\Autodesk Revit Architecture 2010\Data\Rendering\
assetlibrary_base.fbx.

However, if you need to access the Render Appearance Library, which is not stored in 
its default location, click the Browse button in the Render Library Location area of the 
Rendering tab. In addition to the default Render Appearance Library location, you can also 
specify the paths for the additional image fi les defi ning texture, bump map, custom color for 
the render appearance that you can use in the project. These image fi les are not present with 
the software and therefore, you need to specify their paths to use them. To do so, choose the 
Add Value button, in the Additional Render Appearance Paths area and specify the required 
path in the displayed fi eld or choose the Browse button; the Browse for Folder dialog box 
will be displayed. In this dialog box, select the desired path and choose the Open button to 
add the path in the fi eld.

 Spelling Tab 
Revit Architecture provides you the option to run spell check to fi nd spelling errors in the 
text and then rectify them. You can choose the Spelling tab to display its options. Various 
self-explanatory settings can be selected from the Settings list. In the Main Dictionary area 
of this tab, you can select the type of dictionary, to be used as main dictionary for the spelling 
check, from the Autodesk Revit drop-down list.  Apart from the main dictionary, you can also use 
additional dictionaries such as the personal and building industry dictionaries. This facilitates 
the use of various personal and industry related terms in the text matter of the project. There 
are many words that are not included in the main dictionaries but are frequently used in the 
building industry. For example, the abbreviation for concrete ‘conc’ is not available in the main 
dictionaries. The additional building industry dictionary has many such words and abbreviations 
that can be used in the text matter of the project without being prompted for errors while 
checking spellings. You can also add or remove words from your personal and building industry 
dictionary. Choose any of the Edit buttons available in the Additional Dictionaries area to 
view the list of words. You can enter or remove any word from these lists using the cursor and 
keyboard.  To run spell check in your drawing, choose Annotate > Text > Spelling from the 
ribbon; the  Spelling dialog box will be displayed, wherein you can rectify the spelling errors 
in the text by selecting the correct spelling and then choosing the Change button in the dialog 
box, as shown in Figure 2-11. Alternatively, you can press the F7 key to display the Spelling 
dialog box, refer to Figure 2-11, and then make necessary corrections in the text.

 SteeringWheels Tab
The SteeringWheels tab in the Options dialog box is chosen to control the visibility, appearance 
and operational tools of different types of SteeringWheels. This tab has seven different areas 
of control to use the SteeringWheels, as shown in Figure 2-12. The areas are discussed next.   
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Figure 2-11  The Spelling dialog box

Figure 2-12  The SteeringWheels tab of the Options dialog box
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Text Visibility Area
You can control the display of tool messages, tooltips, and tool cursor of the SteeringWheels 
by using the options in the Text Visibility area of the SteeringWheels tab. 

You need to select the Show tool messages check box to enable the visibility of tool messages 
in SteeringWheels. To display the tooltips along with the SteeringWheels, select the Show 
tooltips check box in this area. Similarly, to control the display of the cursor text when a 
-tool is active, use the Show tool cursor text check box. Select this check box to display the
cursor text when the tool is active. 

Big Steering Wheel Appearance and Mini Wheel Appearance Areas
To set the size of the SteeringWheels, select the required option from the Size drop-down list 
in the corresponding areas and set its size to small, normal, or large. Similarly, you can set 
the transparency of the SteeringWheels by selecting the required option from the Opacity 
drop-down list.

Look Tool Behavior and Walk Tool Areas
In the Look Tool Behavior area of the SteeringWheels tab, select the Invert Vertical Axis 
check box to change the vertical axis movement of the view. Selecting the check box enables 
the view to move in the same direction as the cursor in the vertical axis.

In the Walk Tool area of the SteeringWheels tab, use the Speed Factor slider to change the 
speed of the walk, when using the Walk tool of the SteeringWheels. Select the Constrain Walk 
Move parallel to ground plane check box in the Walk Tool area  to constrain the movement 
angle of the walk to ground plane. 

Zoom Tool and Orbit Tool Areas
Select the Zoom in one increment with each mouse click check box in the Zoom Tool area 
to enable the zooming operation with a single click. 

In the Orbit Tool area, select the  Keep scene upright check box to maintain the perpendicularity 
between the sides of the model and the ground plane while using the Orbit tool. 

 ViewCube Tab  
The ViewCube tab in the Options dialog box is used to edit various settings of the ViewCube. It 
has four different areas of modifi cation, ViewCube Appearance, When Dragging the ViewCube, 
When Clicking on the ViewCube, and Compass as shown in Figure 2-13. These areas are 
discussed next.

ViewCube Appearance Area 
The appearance and display of the ViewCube can be  controlled by the ViewCube Appearance 
area in the ViewCube tab.

In the ViewCube Appearance area, the Show the ViewCube check box is selected  by default, 
so the ViewCube will be visible. If you clear this check box, the ViewCube will disappear and 
all options in the ViewCube tab will be deactivated.
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In the ViewCube Appearance area you can use various drop-down lists to  align, resize, and 
change the transparency of the ViewCube. 

Select the options from the On-screen Position drop-down list to align the ViewCube on the 
screen. Similarly, if you want to resize the ViewCube, then select the required option from 
the ViewCube size drop-down list. You can also set the opacity of the  inactive ViewCube by 
selecting various options from the Inactive Opacity drop-down list.

When Dragging the ViewCube Area  
Select the Snap to closest view check box in the When Dragging the ViewCube area in the 
ViewCube tab to enable the snap to select the closest view in the ViewCube.

When Clicking on the ViewCube Area
Select the Fit-to-view on view change check box in the When Clicking on the ViewCube area 
to fi t the view on screen while changing the viewing direction. The Use animated transition 
on switching views check box is selected by default in this area that enables the view to change 
in animation. Clearing this check box will result in the change of view without any animation, 
when using the ViewCube. Select the Keep scene upright check box to keep the sides of the 
ViewCube and the sides of the view perpendicular to the ground plane. Clear the check box 
to turn around the model in full 360-degree swing. Clearing this check box can be useful 
when you are editing a family.

Figure 2-13   The ViewCube tab of the Options dialog box
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Compass Area
The Show the compass with the ViewCube check box in the Compass area is selected by 
default. As a result, the compass along with the ViewCube will be visible in the drawing. 

In the ViewCube tab, you can choose the Restore Defaults button to restore the default settings 
that were changed in its different areas.
  

 CLOSING A PROJECT
To close a project, choose the Application button and then select the  Close option from the 
displayed Application Menu, as shown in Figure 2-14. If you have already saved the latest 
changes, the project fi le will be closed. Otherwise, Revit Architecture will prompt you to save 
the changes through the Save File confi rmation box. You can save the changes by choosing the 
Yes button or discard them by choosing the No button. You can also choose the Cancel button 
to return to the interface and continue working on the project fi le. You can also use the Close 
button (X) in the drawing window to close the project.

EXITING A PROJECT
To exit a Revit Architecture session, choose the Exit Revit button from the Application Menu. 
Even if the project is open, you can still choose the Exit Revit button to close the fi le and exit 
Revit Architecture. In case, the project has not been saved, it enables you to save the work 
through the Save File conformation box, as shown in Figure 2-15. If you choose the No button, 
all changes that were not saved will be lost. You can also use the Close button (X) of the main 
Revit Architecture window (in the title bar) to end the Revit Architecture session.

Figure 2-14  Accessing the Close option 
from Application Menu

Figure 2-15  The Save File confi rmation box

Tip: You must be cautious while choosing the No button in the Save File confi rmation 
box because it discards all the changes made in the project since the last save.
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 OPENING AN EXISTING PROJECT
In Revit Architecture, several options are available to open an existing project.

Opening an Existing Project Using the Open Tool     

To open an existing project fi le, choose  Open > Project from the Application Menu, 
as shown in Figure 2-16. Alternatively, you can open a project by choosing the Open 
button from Quick Access Toolbar or by pressing CTRL+O. On invoking the Open 

tool, the Open dialog box will be displayed, as shown in Figure 2-17. In this dialog box, 
you can open a particular project fi le by accessing the appropriate folder using the Look in 

drop-down list. The Preview area of the Open dialog box shows the preview of the selected 
project fi le. It helps you select a particular fi le by viewing its contents, even if you are not sure 
about the fi le name. The window icons such as the Views menu, placed along with the Look 
in drop-down list help you select a project fi le based on its size, type, and the date when it was 
last saved. On choosing the Thumbnails option from the Views menu, you can preview the 
contents of the project fi les inside the selected folder in the fi le list area, as shown in Figure  
2-18. The Places list is located on the left in the Open dialog box. You can add or remove 
folders from the Places list by choosing the Options button from the Application Menu. On 
doing so, the Options dialog box will be displayed. Choose the File Locations tab from the 
dialog box, and then choose the Places button from it; the Places dialog box will be displayed, 
as shown in Figure 2-19.

The Places dialog box contains two columns: Library Name and Library Path. You can add 
or remove folders in the libraries list to create a list of frequently accessed folders. The four 
buttons on the left of the Places dialog box can be used to create or delete a library, or move 
it up and down in the list. To create a new library, choose the Add Value button, which is the 
third button from the top; a new library will be added to the defi ned path. By default, the name 
of the new library in the Library Name section will be NewLibrary1. Change the name of the 
new library and then click in the Library Path column to display the browse button. Choose 
the browse button and select the folder to be added in the libraries list using the Browse for 
Folder dialog box. Choose the Open button after selecting the folder; the new folder gets 

Application Menu:       Open > Project
Shortcut Key:            CTRL+O

Figure 2-16  Opening an existing project 
using the Application Menu

Tip: The names of the recently opened fi les are displayed at the end of the File 
menu in the interface. On starting Revit Architecture, you can click the name of 
the project fi le that you wish to open.
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added to the list. If required choose the upward arrow button in the Places dialog box to move 
the folder up to the top of the list. Similarly, you can choose the down arrow button to move 
it down.To delete any library, select the library and choose the RemoveValue button. Choose 

Figure 2-18  Previewing the contents inside the fi le using the Thumbnails option

Figure 2-17  The Open dialog box

Tip: By default, the preview of a fi le is the last active view or sheet at the time it was 
last saved. You can set the preview to a particular view from the Options button 
in the Save As dialog box. 
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the OK button in the Places dialog box to exit, and then close the Options dialog box. When 
you invoke the Open tool next time, the new folder icon will be displayed in the places list. 

Once the fi le to be opened has been selected, its name will be displayed in the File Name edit 
box of the Open dialog box and its preview will be displayed in the Preview area.

Note
If you try opening an already opened fi le, which has been modifi ed in the Revit Architecture 
session, a message box appears, prompting you to close the fi le fi rst and reopen it. In case you 
open a fi le that has been created using an older version of Revit, the Program Upgrade message 
box is displayed. It mentions that the fi le is being upgraded to the latest fi le format and that this 
is a onetime process. Once the fi le is opened, it gets upgraded to Autodesk Revit Architecture 
2010 version.

Using the Windows Explorer to Open an Existing Project
Apart from using the Open tool from the Revit Architecture interface, you can also open fi les 
directly from the Windows Explorer by using the methods discussed next.

A fi le can be opened by double-clicking on its icon in the Windows Explorer. It opens 
the project fi le in the latest Revit Architecture session. If Revit Architecture is not running, 
double-click on the fi le icon to start Revit Architecture and then open the fi le.

Tip: When you rest the cursor on the project fi le name, a tooltip appears, which 
provides you the information regarding the type and size of the project fi le.

Figure 2-19  The Places dialog box

Tip: The names of the recently opened fi les are displayed in the Application Menu. 
On starting Revit Architecture, you can click the name of the project fi le that you 
wish to open.
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Another method of opening a project fi le is by dragging the project fi le icon from the Windows 
Explorer and dropping it into the drawing window of the Revit Architecture interface. You 
can also select, drag, and drop more than one fi le in the drawing window. In this case, Revit 
Architecture prompts you to open the fi les in separate windows. Choose the OK button to 
open all fi les in the same Revit Architecture session.

MODEL DISPLAY TOOLS
As described earlier, in Revit Architecture, you can create the building model using the 
3D parametric elements. Various tools are provided to view the building model. Based 
on the requirement, you can use these tools to navigate and edit elements in the building 
model.

Using the  Zoom Tools
The Zoom tools are used to enlarge or reduce a project view in the viewing area. To use this 
tool, you need to invoke the Navigation Bar in your drawing. To do so, choose Window > 
User Interface from the View tab of the ribbon; a cascading menu will be displayed, as shown 
in Figure 2-20. In the cascading menu, select the Navigation Bar check box; the Navigation 
Bar will be displayed in the viewing area. In the Navigation Bar, click on the down arrow 
below the  Zoom in Region tool; a cascading menu will be displayed, as shown in Figure 2-21. 
This cascading menu displays different zooming options, which are discussed next. 

 Zoom In Region
This tool is used to zoom into a specifi ed area or window. When 
you invoke the Zoom In Region tool from the Navigation Bar, 

the cursor is replaced by a magnifying glass. To zoom into an area, you 
need to defi ne a rectangular window by picking its diagonally opposite 
corners. You can click at a point to specify the start point of the 
window. When you move the cursor, a dynamic rectangular window is 
created whose one corner is the specifi ed point and the other corner 
is attached to the cursor. Move the cursor across the area you want to 
enlarge. When the area is enclosed in the rectangle, click to specify the 
diagonally opposite corners of the zoom window. The specifi ed portion 
of the current view is enlarged. For example, to work on the stairs of 
the building plan, you can invoke the Zoom In Region tool and click 
to specify the two opposite corners of the window, as shown in Figure 
2-22. The resulting enlarged view is shown in Figure 2-23.

Figure 2-20  Selecting the Navigation Bar 
check box from the displayed cascading menu

Figure 2-21  Different 
zooming options in the 
cascading menu
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 Zoom Out(2X)
This tool is used to zoom out of the existing view by twice the size of the current view. 
This means, when you invoke this tool, the new view will show twice the length and 

width of the original view. 

 Zoom To Fit and  Zoom All to Fit
The Zoom To Fit tool is used to display all the contents of the project in the current 
view. On invoking this tool, the drawing window will adjust to show all the elements that 

have been created in a view. If there are multiple windows open with different zoom factors, 
invoke the Zoom All to Fit tool to perform Zoom To Fit in all the windows.

Zoom Sheet Size
The Zoom Sheet Size tool is used to fi t the drawings in the default sheet size displayed 
in the Paper tab of the printer’s Properties dialog box. This dialog box will be displayed 

on choosing the Properties button in the Print dialog box. 

 Previous Pan/Zoom and  Next Pan/Zoom 
The Previous Pan/Zoom tool reverts back to the last displayed view using zoom or pan, whereas 
the Next Pan/Zoom tool is a toggle tool to show the next displayed view. 

 Using the Orient Tool
In Revit Architecture, you can view a building model in 3D from the preset viewpoints using 
the Orient tool. 

To activate the Orient tool, fi rst you need to activate the 3D view by double-clicking on {3D} 
under the 3D Views head in the Project browser. Alternatively, you can also activate the 3D 
view by choosing  Create > 3D View > Default 3D from the View tab of the ribbon. On doing 
so, the current view will orient to the default 3D view along with the ViewCube displayed at 

Figure 2-22  Specifying the corners 
of the zoom window

Start 
point

End 
point

Figure 2-23  The resulting enlarged view
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the upper-right corner of the drawing area. Now, place the cursor over the ViewCube and 
right-click; a shortcut menu will be displayed, as shown in Figure 2 -24. Now, in the shortcut 
menu, click on the Orient to a Direction option; a cascading menu will be displayed, as shown 
in Figure 2-25. From this cascading menu, select the appropriate view that will be displayed 
in the drawing window.

 Navigation Tools
Autodesk Revit Architecture 2010 navigation tools help you navigate and maneuver into 
your model in different directions and views. Two new navigation tools have been added 
in Autodesk Revit Architecture 2010, the SteeringWheels and the ViewCube, and these are 
discussed next.

 ViewCube
The ViewCube is an interactive 3D navigation tool that appears in all 3D views of Revit 
Architecture 2010. By default, the ViewCube tool is visible at the top right corner of your 
drawing area.

The ViewCube navigation tool comprises of a cube, a compass ring at the base with various 
directions marked on it, and a home icon that helps you set the default view, as shown in Figure 
2-26. The ViewCube navigation tool is displayed in your drawing area either in the active or 
inactive state, as shown in Figures 2-27 and 2-28. By default, the ViewCube in its inactive state 
and it appears partially transparent over your drawing area, so as to prevent the obstruction of 
the view of your model. Whereas, in its active state, the ViewCube appears opaque and distinct 
and obstructs the view of your model. You can change the size, on-screen placement, visibility 
of the compass, and the inactive opacity of the ViewCube as per your requirement. To do so, 
choose the ViewCube tab from the Options dialog box as discussed earlier. 

In the ViewCube, there are twenty-six defi ned areas, comprising of faces, edges, and corners.  
The twenty-six defi ned areas can be divided into three categories, corner, edge, and face, as 
shown in Figure 2-29. Out of the twenty-six defi ned areas, six areas represent the standard 
orthographic views of a model such as top, bottom, front, back, left, and right. The standard 
orthographic views are set by clicking on one of the faces on the ViewCube. The other twenty 
areas are defi ned to access the angular views of a model.

Figure 2-24  Options in the shortcut 
menu of the ViewCube

Figure 2-25  Options in the cascading 
menu of the Orient to Direction tool
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When you move the cursor on the faces, edges, or vertices of an active ViewCube, the 
corresponding area gets highlighted in dark-gray color. These highlighted regions are called 
hotspots. While using the ViewCube, you can click on these hotspots to orient your view as 
per your requirement.

 SteeringWheels  
The SteeringWheels navigation tools are tracking menus that comprise of multiple navigation 
features in a single interface. Using the features in these tools, you can pan, zoom, walk, 
look, and adjust the view of your model as per your requirement. The SteeringWheels tool 

Figure 2-27  The ViewCube in the active state Figure 2-28  The ViewCube in the inactive 
state 

Figure 2-26  The ViewCube and its various 
components

Figure 2-29  Different area on the ViewCube
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is divided into different sections known as wedges. Each wedge represents a unique function 
for navigation.

To activate the SteeringWheels navigation tool in your model, press the F8 key. The 
SteeringWheels tool will appear according to the state of view in which you are working. If 
you are currently working in a 2D view, you can use the 2D SteeringWheels tool. Similarly 
you can use the 3D SteeringWheels tool when you are working in the 3D view.

In Autodesk Revit Architecture 2010, you can access various types of SteeringWheels from 
the Navigation Bar. In the Navigation Bar, click on the down arrow below the default Full 
Navigation Wheel tool; a shortcut menu with various types of Steering Wheels will be displayed, 
as shown in Figure 2- 30.  

To navigate the 2D view, you can use the 2D navigation wheel, as shown in Figure 2-31. The 
2D navigation wheel has three navigation tools, Zoom, Pan, and Rewind. Zoom is a common 
navigation tool for enlarging  or reducing the viewing scale of the model. You can use the 
Pan tool for traversing across the model view. The Rewind tool can be used to see the views 
of the previous zooming states which are saved temporarily. 

Figure 2-30  Shortcut menu displaying 
various types of SteeringWheels

Figure 2-31  The 2D Steering 
Wheels navigation tool
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The 3D SteeringWheels navigation tools help you navigate through your 3D views. Based 
on the size and appearance, the 3D SteeringWheels is categorized into two groups, Mini 
Steering Wheels and Big SteeringWheels. 

The  Mini SteeringWheels are classifi ed into three types, Mini View Object Wheel, Mini Tour 
Building Wheel, and Mini Full Navigation Wheel, as shown in Figure 2-32.

The Mini View Object Wheel has four distinct navigation tools, Pan, Zoom, Rewind, and Orbit. 
Similarly, the Mini Tour Building Wheel comprises of four unique navigation options, Up/
Down, Look, Walk, and Rewind. The Full Navigation Wheel comprises of eight wedges 
with each wedge defi ning an unique navigation function. The Mini Full Navigation Wheel 
combines all the functions of the Mini View Object Wheel and Mini Tour Building Wheel.
The  Big SteeringWheels has the similar classifi cation as that of the Mini SteeringWheels, as 
shown in Figure 2-33, and it has the same navigation tools as that of the Mini SteeringWheels 
with the only difference in their appearances on screen. 

As you put your cursor over any of the navigation tools, the tooltips and messages are 
displayed, as shown in Figure 2-34. The tooltips inform you regarding the tool that you want 
to use and provide instruction for using it. You can control the visibility of the tooltips and the 
tool messages while using the SteeringWheels by using the Options dialog box, as discussed 
earlier in this chapter.  
 
While using the SteeringWheels navigation tool, you can activate the available navigation tools 
by clicking and holding the left mouse button over any one of the wedges. After holding the 

Figure 2-32  Types of Mini SteeringWheels for 3D Views

Figure 2-33  Appearance of Big SteeringWheels 
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left mouse button and dragging it over the drawing area, you can use the selected navigation 
tool for reorienting your view. Now, to exit the selected navigation tool, release the left 
mouse button.

Other Display Options 
Revit Architecture provides fi ve options to view the building model in different modes of 
shading. You can select these options by clicking on the Model Graphics Style button from 
the View Control Bar. and then selecting the desired option from the shortcut menu that 
will be displayed. There are four options that are available in the shortcut menu and are 
described next.

 Wireframe          : Displays the model with all lines and edges without surfaces
 Hidden Line          : Displays the model with lines and edges by removing those which  
               are hidden by surfaces
 Shading          : Displays the building model with the surfaces shaded with respect   
   to the material shading and default lighting effect
 Shading with Edges : Displays the model with shaded surfaces and all visible lines and   
   edges

Note
By default, these options affect the current view only. However, you can save the shading effects 
by saving the shaded view in the project fi le.

Figure 2-34  Appearance of the tooltip with 
the SteeringWheels
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TUTORIALS 
In the following chapters, you will setup two projects, an apartment complex and a club 
building. Some portions of these two projects will be completed in the tutorials and the rest 
are given as exercises. The tutorials and exercises form a sequence and to complete these 
projects, you will need to complete the tutorials and exercises in the previous chapters. The 
following tutorials will familiarize you with the tools and concepts discussed in this chapter 
such as starting Revit Architecture, opening a new project, setting units, setting snaps, saving 
and closing the project.

In this tutorial, you will create a new project fi le for the Apartment 1 project with the following 
parameters.         (Expected time: 15 min)

1. Template fi le- Imperial Templates > default.rte.
2. Project Units- Feet and fractional inches, Rounding- To the nearest 1/2”.
3. Length dimension snap increment- 5’;2’6”;3”;0’1/2”.
4. File name to be assigned- c02_Apartment1_tut1.rvt

 The following steps are required to complete this tutorial:

a.  Start a Revit Architecture session.
b. Use default.rte as the template fi le for the project, refer to Figure 2-35. 
c. Set Feet and fractional inches as the project units using the Project Units dialog box, 

refer to Figure 2-36.
d. Set 5’;2’6”;3”; 0’1/2” as the length dimension snap increment using the Snaps dialog 

box.
e. Set Endpoint, Midpoint, Nearest, Perpendicular, Work Plane Grid,  and Intersection  

as the object snaps in the Snaps dialog box.
f. Save the project as c02_Apartment 1.rvt using the Save As tool, refer to Figure 2-37.
g. Close the project using the Close tool.

Starting Autodesk Revit Architecture 2010
1.  Start Revit Architecture by choosing Start > Programs > Autodesk > Autodesk Revit 

Architecture 2010 > Autodesk Revit Architecture 2010. The program is loaded and the 
user interface screen is displayed.

Opening a New Project 
1. Click on the Application button; Application Menu is displayed. Choose 

New > Project from this menu; the New Project dialog box is displayed. 
.

Using the Template File
 To use the template fi le for the project, you need to access the appropriate folder and 

select the required template fi le.

Tutorial 1                       Apartment 1
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1. In the New Project dialog box, choose the Browse button; the Choose Template dialog 
box is displayed, showing a list of the template fi les available in the Imperial Templates 
folder.

2. In the Choose Template dialog box, the default.rte template fi le is already selected as 
the default template fi le, as shown in Figure 2-35 . Choose the Open button to close the 
Choose Template dialog box and assign the selected template fi le to the New Project 
dialog box.

3. Use the Project radio button (default) to create a project fi le and choose the OK button 
to close the New Project dialog box; the default.rte template fi le is loaded. Notice that 
the Project browser now shows different levels and views which have already been created 
in the selected template fi le.

Setting the Units
1. To set the units for the project, choose Project Settings > Project Units from the Manage 

tab of the ribbon; the Project Units dialog box is displayed. 

2. Click in the Format column next to the Length parameter; the Format dialog box is 
displayed. 

3. In the Format dialog box, click on the Units drop-down list for setting the length units. 
Select Feet and fractional inches (default option).

4.  Click on the Rounding drop-down list and select the To the nearest 1/2” option, as shown 
in Figure 2-36.

5. Choose the OK button; the Project Units dialog box is displayed. Again, choose the OK 
button to apply the specifi ed units and exit the displayed dialog box. 

Figure 2-35  Selecting the template fi le from the Choose Template dialog box
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Setting Dimension and Object Snaps
 To set the dimension snaps and object snaps, use the Snaps tool. These settings are made 

based on the type of the project and the amount of detailing required.

1. Choose Project Settings >Settings > Snaps from the Manage tab of the ribbon; the 
Snaps dialog box is displayed. In the Length dimension snap increments edit box, type 
5’;2’6”;3”; 0’1/2”;. (Refer to the Snap Settings section of this chapter to know more about 
the Snaps tool)

2. In the Object Snaps area, click on the Quadrants, Centers, Tangents, and Points check 
boxes to disable them. Leave the other options such as Endpoints, Midpoints, Nearest, 
Perpendicular, Work Plane Grid, Snap to Remote Objects, and Intersections enabled. 
Choose the OK button to apply the settings and exit the Snaps dialog box.

Saving the Project
 The project parameters set in the previous steps are an integral part of the project fi le. 

To save this project fi le with these settings, use the Save tool.

1. To save the project, choose the  Save option from the Application Menu. As you are saving 
the project for the fi rst time, the Save As dialog box is displayed. 

2. Browse to the Documents folder and create a folder with the name revit_2010.
 
3. Open the revit_2010 folder and save the fi le with the name c02_Apartment1_tut1.rvt, as 

shown in Figure 2-37. 

Figure 2-36  Setting the Rounding parameter in the Format dialog box
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Closing the Project
1.  To close the project, choose the Close option from Application Menu in the ribbon. As 

you have already saved the latest changes made to the project fi le, choose Close to close 
the project fi le. 

In this tutorial, you will create a new project fi le for the Club project using the following 
parameters.                     (Expected time: 15 min)

1. Template fi le- Imperial Templates > Commercial-Default.rte.
2. Project Units- Feet and fractional inches.
3. Length dimension snap increment- 10’;2’6”;1’; 0’3”.
4. Object snaps to be set- all available object snaps.
5. File name to be assigned- c02_Club_tut2.rvt

 The following steps are required to complete this tutorial:

a.  Start a Revit Architecture session.
b. Use Commercial-Default.rte as the template fi le by accessing the Imperial Templates 

folder. 
c. Set Feet and fractional inches as the project units using the Project Units dialog box.
d. Set 10’;2’6”;1’; 0’3” as the length dimension snap increment in the Snaps dialog box.
e. Enable all the object snaps using the Snaps dialog box.
f. Save the project as c02_Club_tut2.rvt using the Save As tool.
g. Close the project using the Close tool

Tutorial 2                                      Club  

Figure 2-37  Saving the project using the Save As dialog box
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.Starting Revit Architecture and Opening a New Project 
1.  Start a new Revit Architecture session by double-clicking on the Autodesk Revit 

Architecture 2010 shortcut icon on the desktop. The program is loaded and the user 
interface screen is displayed. In case, the Revit Architecture session is already running, 
this step can be ignored and the project fi le can be opened directly.

2. Choose New > Project from Application Menu; the New Project dialog box is 
displayed.

Using the Template File
 As given in the project parameters, you need to use the Commercial-Default template 

fi le for this project. This template fi le can be selected from the New Project dialog box.
 
1. In the New Project dialog box, choose the Browse button; the Choose Template dialog 

box is displayed. From the Imperial Templates folder of the displayed dialog box, select 
the Commercial-Default template fi le and choose Open. Choose OK to exit the New 
Project dialog box.

  
 The Commercial-Default.rte template fi le is loaded. Notice that the Project browser now 

shows several levels that are preloaded in the template fi le.

Setting Units
 You can set the units for various measurement parameters using the Project Units dialog 

box.

1. Choose Project Settings > Project Units from the Manage tab of the ribbon; the Project 
Units dialog box is displayed. 

2. Click in the Format column next to the Length unit; the Format dialog box is displayed. 
In this dialog box, make sure that the Feet and fractional inches option (default option) 
is selected. 

3. Click on the Rounding drop-down list and select To the nearest 1/4”. 

4. Choose OK to return to the Project Units dialog box. Next, choose the OK button to 
apply the settings and return to the user interface screen.

Setting Dimensions and Object Snaps
 Next, access and modify the settings in the Snaps dialog box. You need to specify the 

dimension snap increment and enable all object snap options.  

1. Choose Project Settings > Settings > Snaps from the Manage tab of the ribbon; the 
Snaps dialog box is displayed. 

2. In Object Snaps area, click on the Check All button to enable all object snaps options. 
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3. In the Length dimension snap increments edit box, enter 10’;2’6”;1’; 0’3”; and then 
choose the OK button to apply the settings and exit the Snaps dialog box. 

Saving the Project
 In this section, you will save the project and the settings using the Save As dialog box.
 
1. To save the project with the settings, choose Save As > Project from the Application Menu. 

As you are saving the project for the fi rst time, the Save As dialog box is displayed. 

2. Browse to the revit_2010 folder and enter c02_Club_tut2 in the File name edit box. Notice 
that the File of type drop-down list shows Project Files (*.rvt) as the default option. 

3. Choose the Save button to save the project as c02_Club_tut2.rvt. The project is saved in 
the specifi ed location.

Closing the Project
1. To close the project, choose the Close option from Application Menu. 
 
 The fi le is closed and this completes Tutorial 2 of Chapter 2.

Answer the following questions and then compare them to those given at the end of this 
chapter:

1. You can open only one Revit Architecture project at a time. (T/F)

2. In Revit Architecture, all enabled object snaps work together. (T/F)

3. While saving a project fi le for the fi rst time, when you choose the Save option from 
Application Menu, the Save As dialog box is displayed. (T/F)

4. A project fi le can be opened by double-clicking on the fi le name in the Windows Explorer. 
(T/F)

5. You can save any project fi le as a template fi le. (T/F)

6. The shortcut key to use the Save option is __________.

7. To specify the location of the default template fi le, you can use the __________ tab in the 
Options dialog box.

8. The __________ button in the Save As dialog box can be used to specify the maximum 
number of backup(s) for a project fi le.

Self-Evaluation Test
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9. The __________ option of Revit Architecture enables you to override the snap settings for 
a single pick only.

10. You can add folders to the __________ in the Save As dialog box to access the frequently 
used folders directly.

Answer the following questions:

1. You can modify the project unit settings anytime during the project. (T/F)

2. The project fi le name and path have to be specifi ed each time you save the project. 
(T/F)

3. You cannot control the visibility of the tooltip assistant. (T/F)

4. The Save reminder interval drop-down list that is available in the General tab of the 
Options dialog box is used to specify the time interval between the reminder prompts to 
save the project fi le. (T/F)

5. If the changes made to a project fi le have not been saved, on choosing the Close option, 
Revit Architecture prompts you to save the changes before closing it. (T/F)

6. You can open only one project fi le at a time in a Revit Architecture session. (T/F)

7. You can add words to the additional dictionaries for checking spellings. (T/F)

8. Which of the following options is not an object snap option?

  a) Endpoint    b) Work Plane Grid
  c) Dimension    d) Centers

9. Which of the following keys can be used to toggle between the object snap options available 
at the same point? 

  a) TAB     b) CTRL
  c) ALT     d) F3

10. Which of the following shortcut keys is used to activate the SteeringWheels.

  a) F2                b) F6
  c) CTRL                                                  d) F8

Review Questions
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Create a new project fi le for the Apartment 2 project with the following parameters.
(Expected time: 15 min)

1. Template fi le- Imperial Templates > default.rte
2. Project Units- Feet and fractional inches
3. Length dimension snap increment- 5’;2’6”;3”; 0’1/2”
4. File name to be assigned- c02_Apartment2_ex1.rvt

Create a new project file for the Elevator and Stair Lobby project with the following
 parameters.         (Expected time: 15 min)

1. Template fi le- Imperial Templates > default.rte
2. Project Units- Feet and fractional inches
3. Length dimension snap increment- 5’;1’;3”; 0’1”
4. File name to be assigned- c02_ElevatorandStairLobby2_ex2.rvt

 

Answers to Self-Evaluation Test
1. F, 2. T, 3. T, 4. T, 5. T, 6. CTRL+S, 7. File Locations, 8. Options, 9. Temporary Overrides, 
10. Places list

Exercise 1                                       Apartment 2

Exercises

Exercise 2                             ELevator and Stair Lobby 2



Learning Objectives

Chapter 3

Creating the First Project

After completing this chapter, you will be able to:
• Understand the concept of walls.
• Understand the properties of walls.
• Use the sketching tools to create walls.
• Create exterior walls based on the given parameters.
• Create interior walls based on the given parameters.
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In the previous chapter, you have learned about the procedure of starting and saving a new 
project. In this chapter, you will learn how to use walls as the basic element of a building 
project. 

 CREATING A BUILDING PROJECT
In Autodesk Revit Architecture, the term ‘project’ comprises of not only the physical building 
model but also its associated documentation such as drawings, views, schedules, areas, and 
so on. The fi rst step in creating a project is to create the building model. In Autodesk Revit 
Architecture, you can create it using the following two different methods:

Method 1:  Create a building model using individual building elements such as walls,
  windows, doors, fl oors, roofs, and so on.

Method 2: Create a building model using the Massing tools and conceptualize the
  overall building shape and volume before working with individual 
                          elements. 

The selection of method depends on different project parameters such as project magnitude, 
building shape, building technology, current documentation stage of a project, industry 
parameters, and so on. The use of the Massing tool to create a building geometry will be 
described later in Chapter 10. The following few chapters of this textbook describe the usage 
of individual building components to develop a building model. 

Autodesk Revit Architecture provides you with several tools to add individual building elements 
such as wall, fl oor, roof, and so on for creating a building model. Several predesigned element 
types have been provided for each building element in Autodesk Revit Architecture’s libraries. 
You have the fl exibility to either use the predesigned element types or create your own element 
type to create a building model. 

 Sequence of Creating a Building Model 
The sequence of using building elements for creating a building model may also depend on 
various parameters such as building type, building volume, building shape, and so on. For 
most of the building projects, the sequence given below may be adopted.

Step 1: Start the model by creating the exterior walls of the building at Level 1 (lowest level).

Step 2: Create interior walls at the desired locations.

Step 3: Add doors and windows to the exterior and interior walls at the desired location.

Step 4:  Add the fl oor to the building model.

Step 5: Add the roof to the building model.

Tip: You can also use the combination of the above two methods. You can generate  
building mass using the Massing tools and then convert it into a building model 
with individual building elements. 
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Step 6:  Add the structural or architectural grid and structural elements.

Step 7: Add stand-alone components such as furniture items and plumbing fi xtures.

Step 8: Add text and annotations to different spaces.

Step 9: Create dimensions for different parameters of the project.

Step 10: Create project details and documentation.

Step 11: Create the rendered 3D views and walkthrough.

In Autodesk Revit Architecture, each building element is a three-dimensional parametric entity. 
This means, on adding elements, you also add the related information and specifi cation about 
them. One of the most important elements in a building model is the wall that defi nes the 
basic spatial arrangement of the building and that acts as the host for doors and windows. 

 Understanding  Wall Types
Autodesk Revit Architecture provides you with several predefi ned wall types based on their 
usage such as Exterior, Interior, Retaining, Foundation, and Curtain.

 Exterior Wall Type
This category constitutes the wall types that are primarily used for generating the exterior 
skin of the building model. It has predefi ned wall types such as Brick on CMU, Brick on Mtl. 
Stud, CMU Insulated, and so on.

 Interior Wall Type
The interior walls are used as the interior partitions in a building project. These walls are  
non-bearing in character. The predefi ned interior walls provided in Autodesk Revit Architecture 
have a dry wall construction with a metal stud frame and varying thickness. 

 Retaining Wall Type
As the name suggests, the primary function of the retaining walls is to retain the earth. You 
can either use the retaining walls provided in the program or set the function of any wall type 
as retaining. For example, you can select a wall from the drawing and select Retaining - 12” 
Concrete from the Change Element Type drop-down list. On doing so, the current wall type 
of the wall will be changed to retaining. 

 Foundation Wall Type
The walls that form the foundation or substrate of the main building structure belong to this           
category. To create a foundation wall, the Foundation - 12” Concrete option is provided as 
the predefi ned foundation wall type in the Change Element Type drop-down list. 

 Curtain Wall Type
Apart from these wall types, Autodesk Revit Architecture also has predefi ned curtain walls or 
screen walls that consists of panels and mullions. 
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Autodesk Revit Architecture provides you with the fl exibility of creating your own wall type. 
The walls that you will create can have different functions, which can be modifi ed, depending 
on their functional usage.  

 Creating Walls

In this section, you will learn the method of creating and editing exterior walls. In Autodesk 
Revit Architecture, each wall type has specifi c predefi ned properties such as its usage, 
composition, material, characteristics, fi nish, height, and so on. You can select the wall type 
based on its specifi c usage in the project. Walls, like most other model elements, can be created 
in a plain view or a 3D view. 

To create an exterior wall, fi rst you need to invoke the Wall tool and then select the 
appropriate exterior wall type. To invoke the Wall tool, choose Build > Wall from the Home 
tab of the ribbon, as shown in Figure 3-1; the Place Wall tab will be displayed. In this tab, 
you can select the type of wall from the Change Element Type drop-down list in the Element 
panel, as shown in Figure 3-2. 

Wall Properties
In Autodesk Revit Architecture, wall, like other elements, has two sets of properties, type and 
instance. These set of properties control the appearance and the behavior of the element 
concerned. 

Ribbon:  Home >Build >  Wall
Shortcut Key:  WA

Figure 3-1  Invoking the Wall tool from the ribbon

Figure 3-2  Selecting the wall type from the Change Element Type drop-down list
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Wall Instance Properties
To access the instance properties of a wall, invoke the Wall tool from the ribbon and then 
choose Element > Element Properties > Instance Properties from the Place Wall tab of the 
ribbon. The Instance Properties dialog box will be displayed, as shown in Figure 3-3. 

The Instance Properties dialog box contains the Family and Type drop-down lists. You 
can select the family and the type of the proposed wall, respectively from these drop-down 
lists. The Instance Parameters table in this dialog box shows various parameters and their 
corresponding values for the specifi ed instance of the element. Using it, you can specify the 
instance parameters of the wall element that you will create. The options in this table depend 
on the type and  instance of the selected element or the element to be created as well as on the 
options selected in the Type and Family drop-down lists. The instance properties of exterior 
walls are displayed in different categories such as Constraints, Structural, Dimensions, and 
Identity Data, each representing a set of properties corresponding to the title. You can use 
the twin arrows on the extreme right of the title to collapse the table of properties for each 
title. Some of the important instance parameters are discussed next.

The Location Line parameter indicates the reference line used for creating a wall. In a 3D 
environment, the location line refers to a plane in the wall that does not get modifi ed, even if 
the wall parameters are changed. Click on the Value column; a drop-down list will be displayed. 
Click on the displayed arrow to view the available options. The options in the drop-down list  
are discussed next.

Wall Centerline  -  Center line of the entire composite wall
Core Centerline -  Center line of the structural core of the wall
Finish Face: Exterior -  Exterior face of the wall as the location line
Finish Face: Interior -  Interior face of the wall as the location line
Core Face: Exterior -  Exterior face of the core
Core Face: Interior -  Interior face of the core

The location line is indicated by a dashed line, which appears while sketching a wall segment. 
For example, on selecting Wall Centerline as the location line parameter, you will notice a 
dashed line in the middle of the wall, as shown in Figure 3-4. When you select Finish Face: 
Interior, it appears on the interior face of the wall, see Figure 3-5.

Note 
As the design is developed, you may need to modify certain parameters of the exterior wall such 
as its thickness and composition, based on the fi nal selection of materials and their specifi cations. 
Considering this fl exibility, the location line parameter enables you to create walls.

In Autodesk Revit Architecture, you can specify the height of walls by applying the base and top 
constraints with respect to the levels defi ned in the project. This means once you set the base 
and height parameter of a top story and apply these constraints, all walls will be sketched with 
the same base and the top. To create a wall segment that is not related to these components and 
levels, you can type the desired height in the Value column of the Unconnected Height 
instance parameter. The default value for the unconnected height is 20’0”.
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Tip: The selection for Location Line parameter should be based on your design 
intent. For example, to create walls defi ned by exact interior dimensions, you can 
select Finish Face: Interior as the location line value. Once this parameter is 
selected, any addition or reduction of wall thickness in the project will be done 
towards its outer face.

Figure 3-3  The  Instance Properties dialog box for the Exterior - Brick 
on Mtl. Stud wall type

Figure 3-5  Wall on selecting Finish 
Face: Interior as the location line 

Figure 3-4  Wall on selecting Wall 
Centerline as the location line 
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The instance parameters for walls and their usage are given next. The values of some of the 
instance parameters will be available only after an instance is created. The instance parameters 
of the wall are given in the table below. 

    Instance Parameter                  Description
 Location Line   Line or reference plane for sketching the wall
 Base Constraint   Level or reference plane of the base of a wall
 Base Offset    Height of a wall from its base constraint
 Base is Attached  Check box showing whether or not the base of the wall is   
    attached to any other element
 Base Extension Distance Distance of the base of the layers in a wall
 Top Constraint   Whether the wall height is defi ned by specifi ed levels 
    or is unconnected
 Unconnected Height  Explicit height of a wall
 Top Offset   Distance of the top of a wall from the top constraint
 Top Extension  Distance Distance of the top of a layer on a wall
 Room Bounding  Whether the wall constitutes the boundary of a room
 Related to Mass  Whether the wall relates to a massing geometry
 Structural Usage  Defi nes the specifi c structural usage of a wall
 Length    Shows the value of the length of a wall
 Area    Shows the value of the surface area of a wall
 Volume    Shows the value of the volume of a wall
 Comments   Specifi c comments that give description of a wall
 Mark     To add a unique value or label to each wall
 Phase Created   Phase in which a wall is created
 Phase Demolished  Phase in which a wall was demolished 

Type Properties of Wall
The type properties of a wall specify the common parameters shared by certain elements in 
a family. Any changes made in the type property of a wall element will affect all instances or 
individual elements of that family in the project. 

To modify the type properties of an element, invoke the Wall tool from the Home tab of the   
ribbon; the Place Wall tab will be displayed. Next, from this tab, choose Element > Element 
Properties > Type Properties; the Type Properties dialog box will be displayed, as shown in 
Figure 3-6. Using this dialog box, you can modify the type properties of the selected wall type 
such as Structure, Wall Function, Coarse Scale Fill Pattern, and so on. You can also defi ne 
the composition of the wall type. To do so, choose the Edit button in the Value column of 
the Structure parameter; the Edit Assembly dialog box will be displayed. In Autodesk Revit 
Architecture, a wall is a composite building element and can consist of several layers. Choose 

Tip: For most projects, it is easier to set the levels fi rst and then create the walls.  
You do not need to specify the height because you have already specifi ed the height 
between the levels. You can also set some of the parameters of the wall component 
such as height, top constraint, and location line from the Options Bar.



3-8      Autodesk Revit Architecture for Architects & Designers
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

the Preview button from the  Edit Assembly dialog box to view the graphical representation 
of layers, as shown in Figure 3-7.

Each layer of the composite wall is assigned with a specifi c function and priority based on its 
usage. The layers available in Autodesk Revit Architecture can be broadly classifi ed into the 
categories given next.

Structure [1]- Consists of main supporting element of the structure such as concrete, brick, 
wood, metal stud, and so on.

Figure 3-6  The  Type Properties dialog box for the Exterior- Brick on Mtl. 
Stud wall type
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Substrate [2] - Consists of material that functions as substructure, such as foundation and 
plywood. 

Thermal/Air Layer - Indicates the air cavity or the thermal insulation layer.

Membrane Layer - A zero thickness layer primarily for the prevention against water 
vapor penetration.

Finish 1 [4] - Exterior fi nish such as metal, brick, and stone.

Finish 2 [5] -  Interior fi nish such as paint, gypsum wall board, and so on.

Note
The numbers placed next to certain layers show the priority set of the layer and enables Autodesk 
Revit Architecture to work out the joinery detail of wall segments at corners and intersections 
according to the priority. When joined, a higher priority layer takes precedence over a lower 
priority layer.

The Layers area in the Edit Assembly dialog box displays multiple layers of the selected 
wall, each with a specifi c function, material, and thickness. The layer on the top of the table 
represents the exterior side of a wall and the last layer represents the interior face. The Layers 

Figure 3-7  The  Edit Assembly dialog box with the Preview button chosen
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area, refer to Figure 3-7, displays the selected wall type. In this case, it is Exterior- Brick on Mtl. 
Stud. This wall type has nine layers. The Material column displays the material specifi cation, 
whereas the Thickness column displays the thickness of each layer.  The total thickness of this 
composite wall is the sum of thickness of all layers. In the present case, the total thickness of 
wall is 1’1 7/8” which is given beside the Total thickness parameter on the top of the dialog 
box. You can click on the View drop-down list and select Section: Modify type attributes to 
view the section of the wall.

Autodesk Revit Architecture enables you to add or remove layers using the Insert and Delete 
buttons provided below the Layers area in the Edit Assembly dialog box. To shift the layers, 
choose the Up and Down buttons. You can also create your own layers. You will learn more 
about materials, layers, and composite walls in the later chapters. 

The Default Wrapping area in the Edit Assembly dialog box, has two drop-down lists namely, 
At Inserts and At Ends. These options allow wrapping of the compound walls at the end and 
at the inserts (for door and window openings). The wrapping in the walls can be viewed in 
the plan view. You can select different options to allow wrapping from the At Inserts and At 
Ends drop-down lists in the Default Wrapping area. The Figures 3-8 to 3-11 illustrate the 
wrapping options.

 Sketching Walls
The next step after selecting the wall type from the Change Element Type drop-down list in 
the Element panel is to select the sketching tool. Autodesk Revit Architecture provides several 
sketching tools to sketch the walls of different shapes. These tools, along with the Options 
Bar, can be invoked from the Draw panel in the Place Wall tab of the ribbon, as shown in 
Figure 3-12.

Using  Sketching Tools
In Autodesk Revit Architecture 2010, you can access the sketching tools from the Draw panel 
and the Options Bar in the Place Wall tab of the ribbon. The Line tool is the default option 
for sketching the walls. 

Figure 3-9  The wall created with the Exterior 
option selected from the At Inserts drop-down 
list in the Default Wrapping area

Figure 3-8  The wall created with the Do 
not wrap option selected from the At Inserts 
drop-down list in the Default Wrapping area

Wrapping at wall inserts
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 Sketching Straight Wall Profi les
You can sketch straight walls using the Line sketching tool by specifying the start 
point and the endpoint of the wall segment. To specify the location of the start point, 
click in the drawing area. On moving the cursor in the drawing, you will notice that a 

wall segment is starting from the specifi ed point and the dimension that changes dynamically 
appears on  it. This dimension is called the temporary dimension or listening dimension, and it 
shows the length and angle of the wall segment at any given location of the cursor, as shown in 
Figure 3-13. Also, notice that the cursor moves in increments by the value set in the Dimension 
Snaps option of the Snaps dialog box (See Chapter 2, Setting Snaps). The angle subtended 
by the wall on the horizontal axis is also displayed and it keeps changing dynamically as you 
move the cursor to modify the inclination of the wall. Also notice that, on bringing the cursor 
near the horizontal or the vertical axis, a dashed line will appear on the wall segment. This is 
called the alignment line and it helps you sketch the components with respect to the already 
created components. You will also notice a tooltip is displayed indicating that the wall segment 
being sketched is horizontal, as shown in Figure 3-14. 

Autodesk Revit Architecture provides you the fl exibility of specifying the length of the walls in 
different ways. The fi rst option is to specify the starting point of the wall, move the cursor in the 
desired direction and click when the angle and the temporary dimension attain the required 
values. The second option is to sketch the wall and then modify its length and angle to the 
exact value. For example, to sketch a 18’0” long horizontal wall after specifying the starting 

Figure 3-11  The wall created with the Exterior option 
selected from the At Ends drop-down list in the 
Default Wrapping area

Figure 3-10  The wall created with the None 
option selected from the At Ends drop-down 
list in the Default Wrapping area

Wrapping at
 wall ends

Figure 3-12  Wall sketching options available in the Draw panel and the Options Bar of the 
ribbon
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point, you can move the cursor to the right until you see a dashed horizontal line parallel to 
the sketched wall. Click when the temporary dimension shows 20’0” approximately. Note that 
the length of the wall may not be exactly 18’0”. You can now use the wall controls to modify 
the dimensions of the wall to its exact value. 

To modify the wall, select the wall segment and view its control and properties. As you select 
the wall segment, it gets highlighted in blue and three symbols appear in blue above the wall 
segment, as shown in Figure 3-15. 

The exact dimension of the sketched wall is visible in the dimension text of the temporary 
dimension. The conversion control symbol, which appears below the dimension value, is used 
to convert the temporary dimension into a permanent dimension. The two blue arrows, which 
also appear on the upper face of the wall, indicate the fl ip control symbol for the sketched walls. 
They appear on the side interpreted as the exterior face of the wall. By default, the walls drawn 
from the left to right have the external face on the upper side and the walls drawn from the top 
to bottom have it on the right side. You can fl ip the orientation of the wall by clicking on the 
arrows symbol. Alternatively, you can place the cursor over the fl ip control symbol and notice 
the change in its color. After the color of the fl ip control changes, press SPACEBAR to fl ip the 
wall. The two blue dots that appear at the two ends of the wall segments are the drag control 
symbols. You can use them to stretch and resize the walls. To set the wall to the exact length, 
click on the temporary dimension; an edit box  will appear showing the current dimension 
of the wall segment. Now, you can replace it by typing the exact length, in this case 14’ 8”, in 
the edit box, as shown in Figure 3-16. The length of the wall will be modifi ed to 14’ 8”. 

Figure 3-14  Sketching a horizontal wall Figure 3-13  Sketching a wall using 
the Line option

Figure 3-15  Highlighted wall displaying its controls
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Alternatively, you can create a straight wall by typing the dimension of the length before 
choosing the endpoint. As soon as you start typing the length, an edit box appears above the 
dimension line. Enter the value of the length and press ENTER to create a wall segment of 
the specifi ed length. To sketch a wall at a given angle, sketch it at any angle and then click 
on the angular dimension symbol; an edit box will appear. In the edit box, you can enter the 
exact angular dimension from the horizontal axis to which the wall will be inclined. 

Note
The Project browser shows Level 1 in bold letters. This indicates that the wall has been sketched 
in that level.

 Sketching Rectangular Wall Profi les
You can invoke the Rectangle sketching tool from the Draw panel in the Place Wall tab 
of the ribbon to sketch a rectangular wall profi le. After you invoke the Rectangle tool, 

click on the screen to specify the location of one corner of the rectangular wall to be drawn. 
Next, move the cursor away from the point; a rectangular wall profi le will be displayed along 
with the temporary dimension between the two parallel walls. Now, move the cursor to the 
desired location and when the temporary dimension attains the desired value, click to specify 
the diagonally opposite corner of the profi le; the rectangular wall will be created along with 
the temporary dimensions displayed. Alternatively, you can also create a rectangular wall 
profi le by sketching it using some rough dimension and then modifying its size. This can be 
done by clicking on the temporary dimension of the sketched profi le and entering the exact 
distance in the edit box, as shown in Figure 3-17. The size of the rectangle will be modifi ed 
to the exact values.

Figure 3-16  Specifying the exact length of the wall

Figure 3-17  Creating and modifying a rectangular wall profi le 
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 Sketching Polygonal Wall Profi les 
You can sketch a polygonal wall profi le using any one of the tools, Inscribed Polygon 
or Circumscribed Polygon from the Draw panel in the Place Wall tab of the ribbon. 
When you invoke any of these tools, various options for polygon creation are displayed 

in the Options Bar. In this bar, you can specify the number of sides of the polygon in the 
Sides edit box. The polygonal profi le can be created by specifying the radius of the inscribed 
or circumscribed circle. To draw an inscribed polygon, choose Draw > Inscribed Polygon 
in the Place Wall tab of the ribbon and then specify the desired number of sides, height (if 
unconnected), and offset value in the respective edit boxes in the Options Bar. Next, click 
in the drawing area to specify the center of the polygon, and then drag the cursor and click 
again to get the desired radius; the inscribed polygon will be created. Similarly, a circumscribed 
polygon can also be created by choosing Draw > Circumscribed Polygon in the Place Wall 
tab of the ribbon.    

 Sketching Circular Wall Profi les 
The Circle sketching tool can be used to sketch a circular wall profi le. To invoke this tool, 
invoke the Circle tool from the Draw panel of the Place Wall tab and click in the drawing 

area to specify the center point of the circular wall. You will notice that a circular wall profi le 
is extending dynamically with the specifi ed point as the center and the other end attached to 
the cursor. The temporary radial dimension will also be displayed, as shown in the Figure 3-18. 
Click when the desired value for the radius is displayed. Alternatively, before clicking on the 
second point, type the value for the radius of the circular profi le. As you type, the value will 
be displayed in the edit box. Press ENTER to complete the profi le. Notice that the dimension 
that you entered is the distance of the center point to the location line of the profi le. 

Sketching Start-End-Radius Arc  
The Start-End-Radius Arc sketching tool in the Draw panel in the Place Wall tab of 
the ribbon enables you to sketch an arc wall by specifying the start point, end point, and 

the intermediate point that determines the radius of the arc. To create an arc wall, invoke the 
Start-End-Radius Arc tool from the Draw panel of the Place Wall tab; you will be prompted 
to specify the start point of the proposed arc wall. Specify the start point by clicking in the 
drawing area. Now, you will be prompted to specify the endpoint of the curved wall. Specify 

Figure 3-18  Sketching the circular wall profi le



Creating the First Project                        3-15

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

the endpoint of the curved wall; a curved wall with a variable radius stretches dynamically 
between the two specifi ed points. Specify the location of the third point between the two 
specifi ed points to specify the subtended angle or the radius of the arc. As you specify the 
third point, the angular and radial temporary dimensions are displayed along with the curve 
on the screen. Next, click in the drawing area to specify the third point; the curved wall will be 
sketched. You can also modify the sketched wall to the desired curvature parameters such as 
radius, angle subtended, orientation, and so on. To modify the curvature, select the sketched 
wall, click on the parameter such as the angular dimension and enter the new value, as shown 
in Figure 3-19. You can also use the drag controls to increase or decrease the extent of the wall. 
The central blue dot can be used to stretch the wall, keeping the subtended angle constant.

 Sketching Center-ends Arc
You can sketch a curved wall by specifying its center point and two endpoints. To do so, 
choose Draw > Center-ends Arc from the Place Wall tab of the ribbon.  Next, click in 

the drawing area to specify the location of the center point and then move the cursor. Click 
when the desired value of the radius is displayed. You can also type the radius value and then 
press ENTER. The point that you specify will be taken as the start point of the wall. Next, 
click in the drawing area again to specify the endpoint of the arc wall. Note that the curved 
wall segment can be extended up to 180-degree. When the angle exceeds 180-degree, the 
wall will fl ip the side. Once the wall is sketched, you can select it and modify its parameters 
such as its subtended angle and radius. You can also modify the curvature keeping the radius 
fi xed by using the drag controls, as shown in Figure 3-20.

Figure 3-19  Sketching and modifying a curved wall profi le

Figure 3-20  Sketching a curved wall profi le using 
the Center-ends Arc sketching tool
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 Sketching Tangent End Arcs
To sketch a curved wall profi le that starts tangentially from an existing wall, invoke the 
Tangent End Arc tool. To do so, choose  Draw > Tangent End Arc from the Place Wall 

tab of the ribbon; the start point of the wall can be specifi ed as the end point of an existing 
wall. After specifying the start point, move the cursor to the desired distance and click to 
defi ne the curved wall profi le.

 Sketching Fillet Arcs
To create a curved fi llet wall between the two 
existing walls, choose Draw > Fillet Arc in the 
Place Wall tab of the ribbon. Now, one by one, 
click on the two walls to create a fi llet close to 
the desired fi llet end. A fi llet wall will appear, 
showing its possible locations, as shown in 
Figure 3-21. Click to specify the location of the 
fi llet. Once the fi llet wall is sketched, you can 
modify its radius by clicking on it and typing its 
value. Notice that the walls are automatically 
trimmed after placing the fi llet arc.

Using the Chain Option
The Chain option in the Options Bar is used to create a continuous wall profi le with a number 
of wall segments. It enables you to create a continuous wall with wall segments connected end 
to end. The end point of the previous wall becomes the start point of the next wall. To enable 
the Chain option, select the check box before or while sketching the wall profi le. You can also 
use this option while using different sketching options.

Using the Offset Option
The Offset option is used to create a wall that starts at a specifi ed offset distance from a point 
defi ned in an existing element. You can enter the offset distance value in the edit box provided 
in the Options Bar. However, the shape of the resulting wall depends on the sketching tool 
selected. After entering the offset value and selecting the sketching option, click near the 
element to defi ne the offset distance. When you move the cursor, the wall will start at the 
specifi ed distance from the selected point. For example, this option can be used for creating 
boundary walls that are placed at a specifi c distance from the building profi le.

Using the Radius Option
The Radius option is used to specify the radius while sketching a circular, curved, or a fi llet 
wall. You can type the value of the radius in the text box before or after invoking the desired  
sketching tool.

 SKETCHING  INTERIOR WALLS
In Autodesk Revit Architecture, interior walls form a separate family of wall types. They differ 

Tip: An appropriate sketching option should be selected based on the desired 
wall profile. You can also sketch walls using a combination of available 
sketching options.

Figure 3-21  Sketching a fi llet arc wall profi le
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from the exterior wall types based on their usage, material 
specifications, and non load-bearing character. Several 
predefi ned interior wall types are provided in the Autodesk 
Revit Architecture libraries.
 
To view the interior wall types, choose Build > Wall from the 
Home tab in the ribbon; the Place Wall tab will be displayed. 
From this tab, select the Change Element Type drop-down list 
in the Element panel. The Change Element Type drop-down 
list displays  different type of walls available in Autodesk Revit 
Architecture. The wall types that may be used as interior walls 
have been assigned the prefi x Interior. Based on the project 
requirement, you can select the appropriate interior wall 
type from the drop-down list. For example, Interior- 5” 
Partition (2-hr) is a type of interior wall with a 2-hour fi re 
rating and can be selected from the Change Element Type 
drop-down list, as shown in Figure 3-22.

To view and specify the instance properties of an interior 
wall type, choose Element > Element Properties > Instance 
Properties from the Place Wall tab of the  ribbon; the 
Instance Properties dialog box will be displayed, as shown 
in Figure 3-23. This dialog box shows various instance parameters of the selected wall such 
as Unconnected Height, Location Line, Structural Usage, Top Constraint, and so on. You 
can modify these parameters by entering a new value or selecting the required value from the 
corresponding Value column in the Instance Properties dialog box. 

The sketching options explained earlier (for exterior walls) can also be used for sketching interior 
walls. When you sketch the interior walls, the top constraint of the interior walls is automatically 
set to a level above the current level. 

Note
The interior walls do not create a neat junction with the exterior walls as they have different 
composition and characteristics. Walls are the host elements for other building elements such as 
doors and windows. Therefore, deleting walls will delete all their dependent elements as well.

The basic composition of an interior wall type can be viewed by choosing Element > Element 
Properties > Type Properties in the Place Wall tab of the ribbon. On doing so, the Type 
Properties dialog box will be displayed, showing different type parameters of the selected 
wall type.

To view the structural composition of a wall type, choose the Edit button for the Structure 
type parameter; the Edit Assembly dialog box will be displayed, showing layers for the 
corresponding wall type. For example, the Interior - 5” Partition (2-hr) wall type comprises 

Figure 3-22  Selecting the 
interior wall type from the Change 
Element Type drop-down list

Tip: The Location Line parameter in the Instance Properties dialog box of wall 
selected is useful for creating interior walls. You can create interior walls at a specifi ed 
distance from another existing wall using the Finish Face: Interior option.
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Tip: Besides the Change Element Type drop-down list, wall types are also listed 
under the Families head in the Project browser. Left-click on the plus sign (+) next 
to the Families head to view the families available in Autodesk Revit Architecture. 
Click the ‘+’ symbol next to the Wall subhead and then the one next to the Basic 
Wall subhead to display various basic wall types. Select and right-click on any wall 
type to display a shortcut menu with the options that can be used for editing. For 
example, to select all instances of a particular wall type from the drawing, right 
click on the corresponding wall type and then choose the Select All Instances 
option from the shortcut menu. 

Figure 3-23  The Instance Properties dialog box for the Interior - 5” 
Partition (2-hr) wall type
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buttons to modify the wall type. The Preview button shows a graphic view of the Interior-5” 
Partition(2 -hr) wall type, as shown in Figure 3-24.  

The following tutorials are designed to familiarize you with the concepts of invoking the 
Wall tool, selecting the wall type, modifying its properties, using the sketching options, and 
sketching a wall with the given parameters.

TUTORIALS 

Create the exterior walls of a two-room apartment based on the sketch plan shown in 
Figure 3-25. The dimensions have been given only for reference and are not to be created in 
this tutorial. The parameters to be used for creating the exterior walls are given next.

 (Expected time: 30 min)

Tutorial 1          Apartment 1

Tip: While creating a new wall type, you can specify whether a wall is an exterior 
or interior wall. To do so, invoke the Type Properties dialog box of the wall to be 
created and click in the Value fi eld of the Function parameter; a drop-down list 
will be displayed. From this drop-down list, you can select the Exterior option to 
assign exterior wall type function to the selected wall. Similarly , you can select the 
Interior option to assign the interior wall type function to the wall.  

Figure 3-24  The Edit Assembly dialog box for the Interior-5” Partition (2-hr) wall type 



3-20      Autodesk Revit Architecture for Architects & Designers
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

1. Project fi le-c02_Apartment_tut1.rvt created in Tutorial 1 of Chapter 2.
2. Exterior wall type- Basic Wall: Exterior - Brick on Mtl. Stud 
3. Location line parameter- Wall Centerline; Top Constraint- Up to Level 2

 The following steps are required to complete this tutorial:

a.  Open the Apartment 1 project fi le created in Tutorial 1 of Chapter 2. 
b. Invoke the Wall tool from the ribbon.
c. Select the exterior wall type Exterior - Brick on Mtl. Stud from the Change Element 

Type drop-down list.
d. Modify Top Constraint- Up to level: Level 2 and Location Line - Wall Centerline   

as wall properties using the Element Properties button, refer to Figure 3-26.
e. Invoke the Line sketching tool and then sketch the exterior walls based on the given 

parameters, refer to Figures 3-26 through 3-35.

Opening an Existing Project 
1.  Choose Open > Project from the Application Menu and open the c02_Apartment1_tut1.rvt 

project fi le. You can also download this fi le from:
 http://www.cadcim.com/Revit_2010/Revit_2010.htm link.

Invoking the Wall Tool and Selecting the Wall Type
 As mentioned earlier, to start sketching the wall, you must invoke the Wall tool from the  

ribbon and select the wall type to be used (Exterior - Brick on Mtl. Stud in this case). 

1. Invoke the Wall tool by choosing Build  > Wall from the Home tab of the ribbon; the 
Place Wall tab is displayed.

Figure 3-25  Sketch plan for creating exterior walls for the Apartment 1 project
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2. From the Element panel of the Place Wall tab, select the Exterior - Brick on Mtl. Stud 
from the Change Element Type drop-down list.

Modifying Properties of the Exterior Wall 
After selecting the wall type, you need to modify the properties of the wall type using the 
Instance Properties dialog box. The default.rte template fi le used for this project has two 
predefi ned levels: Level 1 and Level 2.

1. Choose Element > Element Properties > Instance Properties in the Place Wall tab of 
the ribbon; the Instance Properties dialog box is displayed.

 
2. Make sure that the Location Line parameter has Wall Centerline as the default value. 

Click on the fi eld under the Value column for the Top Constraint instance parameter; a 
drop-down list is displayed. Select Up to level: Level 2 from this drop-down list, as shown in 
Figure 3-26. Exit the dialog box by choosing the OK button to return to the interface screen. 

Sketching the First Exterior Wall Segment 
 To sketch a wall, you need to select an appropriate sketching tool from the Draw panel in 

the Place Wall tab of the ribbon. The exterior walls of the given sketch of the Apartment 1 
project can be created using the Rectangle option. You will, however, use the Line option 
to learn and understand the usage of this tool for sketching the straight walls. 

1.   Choose the Line tool from the Draw panel in the Place Wall tab of the ribbon and then 
ensure that the Chain check box is cleared in Options Bar.

2. To specify the start point of the fi rst wall segment, click between the four inward arrow 
keys. Next, move the cursor toward the right hand side. Notice that a wall segment starts 
from the specifi ed point and a temporary dimension appears, which changes dynamically 
as you move the cursor. This shows the length of the wall segment at any given location 
of the cursor.

Figure 3-26  Setting the Top Constraint parameter using the Instance Properties dialog box
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3. Right click in the drawing area; a shortcut menu is displayed. Choose the  Zoom In Region  
option from the shortcut menu and zoom into the area to get a closer view of the sketched 
wall segment, as shown in Figure 3-27 (for zooming techniques, see Chapter 2- Getting 
Started with Revit Architecture). 

4. Move the cursor on the horizontal axis so that the dashed line appears at the central axis 
of the wall segment, as shown in Figure 3-28. Notice the two-sided arrow attached to the 
endpoint of the wall. This indicates that the wall segment being sketched is horizontal. A 
tooltip indicating the horizontal alignment is also displayed.

5. Move the cursor to the right until the temporary dimension shows the value to be more 
than 40’0”. Click at this location as the endpoint of the wall segment and press ESC  
twice; the wall is created. The created wall shows its temporary dimension, a dimension 
symbol, and a twin-arrow symbol, as shown in Figure 3-29. Note that, if the dimension is 
not displayed, you need to click on the created wall to display the dimension.   

Figure 3-28  Sketching a horizontal wall segment

Figure 3-29  The sketched horizontal wall with its controls

Figure 3-27  The angle and temporary dimensions are displayed on the wall being sketched
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Note
You can create a wall of exactly 40’0” length using the dimension snaps set in the Snaps dialog 
box. The only purpose of creating a wall more than the desired length in this step is to explain 
how to modify the length of the sketched wall to the exact value.

Modifying the Length of the Sketched Exterior Wall
 You will now modify the length of the sketched wall to the actual dimension, as given in 

the Apartment 1 sketch.

1. Select the created wall and click on the displayed temporary dimension. An edit box 
appears showing the current dimension of the wall segment. 

2. Enter 40’0” in the edit box, as shown in Figure 3-30 and then press ENTER. The wall 
length is modifi ed to 40’0”.Press ESC to exit from the Modify Walls tab. 

Note
By default, the exterior face of the walls drawn from the left to right is on the upper face and 
for those drawn from the top to bottom on the right face. Similarly, the exterior face of the walls 
drawn from the right to left is on the lower face, and for those drawn from the bottom to top 
on the left side. Hence, you can minimize the use of the fl ip tool by sketching the walls in the 
appropriate direction.

Sketching Other Exterior Wall Segments
 In this sections, you need to create other exterior wall segments using the Endpoint object 

snap tool.

1. Choose Build > Wall in the Home tab of the ribbon; the Wall tool is invoked. Now, bring 
the cursor close to the right endpoint of the fi rst wall segment. When the cursor shows 
a square box at the endpoint (indicating the Endpoint object snap), as shown in Figure 
3-31, click to specify the start point of the second wall segment. 

2. As you move the cursor, a dynamic wall starts with one end attached to the specifi ed point 
and the other attached to the cursor. Move the cursor vertically downward so that you 

Figure 3-30  Modifying the length of a wall segment using temporary dimensions

Tip: To exit the current tool, invoke any other tool or right-click and choose Cancel 
from the shortcut menu to discontinue it.
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length; an edit box is displayed with the dimension that you have entered, as shown in 
Figure 3-32. Press ENTER; the second wall segment is sketched to exactly 20’0” length. 
Notice that the intersection of the fi rst and the second wall segment has been intuitively 
fi lled or completed. 

3. To draw the third wall segment, use the Chain option. Enable it by selecting the Chain 
check box from the Options Bar. 

4. Move the cursor close to the endpoint of the second wall segment and click when the 
endpoint object snap is displayed. The third wall segment starts from this specifi ed point. 
Move the cursor horizontally towards the left. Now, hold the SHIFT key while moving the 
cursor. 

 Notice that the cursor can now move only in the orthogonal directions i.e. horizontal and 
vertical directions. When the length of the wall segment is around 40’0”, a vertical dashed 
line originates from the start point of the fi rst wall segment. The alignment line shows 
the point on the third wall segment that is in plumb with the fi rst point. An intersection 
snap symbol indicated by an X appears at this point, as shown in Figure 3-33. 

5. Click when the intersection snap symbol is displayed to specify the location of the endpoint 
of the third wall segment. 

6. You have enabled the Chain option and therefore, the next wall segment automatically 
starts from the last specifi ed point. Hold the SHIFT key and move the cursor vertically 
upward. Enter 25’0”, as shown in Figure 3-34 and press ENTER to create a vertical wall 
segment. The fourth wall segment is created.

Figure 3-31  Starting a second exterior wall segment using the Endpoint object snap option

Figure 3-32  Creating the second exterior wall segment
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Note
The only purpose of creating a wall of more than the desired length in this step is to explain how 
to stretch the wall to the exact length.

7. Press ESC twice to exit the Wall tool. 

Stretching the Wall Segment 
 You will now stretch the wall segment to reduce its length to the desired dimension by 

using the drag controls. 

1. Select the fourth wall segment to display its controls. The two blue dots at its two endpoints 
are the drag controls. Move the cursor near the upper dot; the color of the drag control 
symbol changes, as shown in Figure 3-35. Press and hold the left mouse button at this 
point and drag the cursor vertically downward and bring it close to the start point of the 

Figure 3-34  Sketching the fourth exterior wall segment

Figure 3-33  Creating the third wall segment
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fi rst wall segment. The endpoint object snap is displayed at the intersection of two walls 
and the tooltip shows Endpoint and Vertical. 

2. Release the left mouse button at the intersection point to reduce the length of the fourth 
wall segment; the fi rst and fourth wall segments are joined at the corner with their ends 
completed. Note that if these wall segments do not join at the corner on releasing the left 
mouse button, then you need to click at their intersection. 

3. Press ESC to remove the wall segment from the selection set. The external wall profi le is 
completed for this tutorial, as shown in Figure 3-36.

 
4. Choose Save As > Project from Application Menu; the Save As dialog box is displayed. 

Enter c03_Apartment1_tut1 in the File name edit box and then choose Save.

     This completes the creation of the external wall segments for the Apartment 1 project.

Figure 3-35  Using the drag control to modify the length of wall

Figure 3-36  The completed exterior wall profi le
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Create the exterior walls of the club building whose sketch plan is shown in Figure 3-37. 
The given dimensions are measured from the exterior faces and are not to be created. The 
parameters to be used for different elements are given next.   (Expected time: 30 min)

1. Project- c02_Club_tut2.rvt project created in Tutorial 2 of Chapter 2.
2. Exterior wall type- Exterior - Split Face and CMU on Mtl. Stud.
3. Unconnected height of walls- 15’0”.
4. All inclined walls are at 45-degree to the horizontal axis.

 The following steps are required to complete this tutorial:

a.  Open the c02_Club_tut2.rvt project fi le created in Tutorial 2 of Chapter 2. 
b. Invoke the Wall tool.
c. Select the exterior wall type: Exterior- Split Face and CMU on Mtl. Stud.
d. Set the unconnected height to 15’0”.
e. Change the Location Line parameter to Finish Face: Exterior, refer to Figure 3-38.
f. Select the Line sketching option and sketch the inclined wall profi le using the Chain 

option, refer to Figures 3-39 through 3-45.
g. Use the Center-ends Arc sketching option to create the curved wall, refer to Figures 3-46 

and 3-47. 

Tutorial 2                                                    Club

         Figure 3-37  Sketch plan for the Club project
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Opening the Project 
1.  Choose Open > Project from Application Menu and open the c02_Club_tut2.rvt project 

fi le created in Tutorial 2 of Chapter 2. You can also download this fi le from:
 http://www.cadcim.com/Revit_2010/Revit_2010.htm link.

Invoking the Wall Tool and Selecting the Wall Type
 First, you will invoke the Wall tool from the ribbon and then select the specifi ed exterior wall 

type Exterior - Split Face and CMU on Mtl. Stud, as given in the project parameters.

1. Choose Build > Wall from the Home tab of the ribbon; the Place Wall tab is 
displayed.

2. In the Element panel of the Place Wall tab, select Exterior - Split Face and CMU on 
Mtl. Stud from the Change Element Type drop-down list. 

Modifying Properties of the Exterior Wall
 Next, you will use the Instance Properties dialog box to modify the unconnected height 

to 15’0”. The dimensions given in the sketch are exterior wall face dimensions, therefore, 
you need to set the location line parameter to Finish Face: Exterior. 

1. Choose Element > Element Properties > Instance Properties  in the Place Wall tab of 
the ribbon; the Instance Properties dialog box is displayed. In the Value column of this 
dialog box, replace the current value for the Unconnected Height parameter  by entering 
15’0”.

2. Click in the Value column of the Location Line parameter and choose the Finish Face: 
Exterior option, as shown in Figure 3-38. Choose the OK button to accept the specifi ed  
values and close the dialog box to return to the interface screen.

Sketching the Inclined Exterior Walls
 Start creating the exterior wall profi le by fi rst sketching the inclined walls fi rst in a 

sequence such that the exterior face of the wall is on the external side. You will use the 
Chain option to sketch the continuous wall profi le. Once you create the fi rst inclined wall, 
the other parallel and perpendicular walls can be easily created using the alignment lines 
and different object snaps options. 

1. To create the straight wall, choose the Line tool in the Draw panel from the Place Wall 
tab of the ribbon.

2. In the Options Bar, enable the Chain option by selecting its check box, if it is not already 
checked.

3. To start sketching the fi rst inclined wall segment, click inside the four arrow keys in the 
drawing window and move the cursor upward toward the right. Move the cursor to an 
inclination such that the angle subtended to the horizontal axis is 45 degrees.



Creating the First Project                        3-29

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

4. Enter the value 14’0” to specify the length of the fi rst wall segment; the value is displayed 
in the edit box, as shown in Figure 3-39. Press ENTER to create the fi rst wall segment of 
the specifi ed length.

5. The Chain option is enabled and therefore the second wall segment starts from the last 
specifi ed point. Move the cursor downward towards the right and right-click to invoke the 
shortcut menu. Choose Snap Overrides > Perpendicular from the displayed shortcut 
menu; the perpendicular snap symbol appears at the end of the wall. Enter 60’0”, see 
Figure 3-40. The wall perpendicular to the fi rst inclined wall is created.

6. Similarly for the next wall, move the cursor downward to the left and  choose the 
perpendicular snap override as in step 5 . Enter 40’0” as length, as shown in Figure 3-41. 
Now, press ENTER to create the third inclined wall. 

7. To create the next wall, move the cursor upward toward left and invoke the perpendicular 
snap override as in the step 5. Enter 60’0” as the wall segment length and press ENTER 
to create the fourth inclined wall segment, as shown in Figure 3-42.

8. Similarly, create the fifth inclined wall segment of 60’0” length, as shown in 
Figure 3-43.

Figure 3-38  Setting the location line parameter in the Instance Properties table of 
the Instance Properties dialog box

Figure 3-40   Sketching the second inclined wall 
segment

Figure 3-39  Sketching the fi rst inclined wall 
segment
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9. Next, create the connected wall segment of 40’0” length, as shown in Figure 3-44. 

9. Now, create the next two wall segments of 60’0” and 14’0” length to complete the inclined 
wall exterior profi le, as given in the sketch plan and shown in Figure 3-45. 

10. Press the ESC key to discontinue the wall at this point and fi nish sketching the inclined 
walls.

Sketching the Curved Exterior Wall
 Next, you will sketch the curved exterior wall profi le based on the given parameters. You 

need to use the Center-ends Arc tool to create the curved wall segment.
 
1. Choose the Center-ends Arc button in the Draw panel from the Place Wall tab of the 

ribbon. Move the cursor in the drawing window and click on the outer intersection of the 
inclined walls to specify the center of the curved wall. Refer to Figure 3-46. 

2.  Move the cursor near the endpoint of the last sketched inclined wall segment. When 
135-degree is displayed as the angular dimension, enter the value 27’0” as the radius of 
the curved wall, as shown in Figure 3-46. The curved wall with the specifi ed radius starts 
from the specifi ed point.

Figure 3-42  Sketching the fourth inclined wall 
segment

Figure 3-41  Sketching the third inclined wall 
segment

Figure 3-43  Sketching the fi fth inclined wall 
segment

Figure 3-44  Sketching the sixth inclined wall 
segment
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Note
While tracking the wall, if the perpendicular or other snapping symbol does not appear, you 
can right click and choose Snap Overrides; a cascading menu will be displayed. Choose any 
snapping options from the displayed cascading menu. On doing so, the desired snapping symbol 
will appear for the specifi ed point or action. 

3. Move the cursor toward the right and click when the cursor snaps to the endpoint of the 
inclined wall, as shown in Figure 3-47. Now. press ESC twice to complete the exterior wall 
profi le, as shown in Figure 3-48.

Figure 3-45  The sketched inclined wall exterior profi le

Figure 3-48  Completed layout of the exterior walls for the Club project

Figure 3-46  Starting the curved wall segment Figure 3-47  Completing the curved wall 
segment
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4.  From the View Control Bar, choose the Model Graphics Style button; a fl yout is displayed. 
Choose the  Shading with Edges option from the fl yout.

5.  Now, from the View tab of the ribbon, choose Create > 3D View> Default 3D. The view 
of the building model view will appear, as shown in Figure 3-49.

6. Under the Floor Plans head in the Project browser, double-click on Level 1 to return to 
the plan view.

7. Choose Save As > Project from Application Menu; the Save As dialog box is displayed. 
Enter c03_Club_tut2 in the File name edit box and then choose Save.

This completes the tutorial for creating the exterior wall profi le for the Club project.
In this tutorial, you will add interior walls to the apartment plan created in Tutorial 1 of this 
chapter. The interior walls to be created are the intermediate walls among various rooms, as  shown 
in the plan sketch in Figure 3-50. The dimensions and text have been given for reference and 
are not to be created. The parameters to be used for different elements are given next.
          (Expected time: 30 min)   
                                                                                     
1. Project- c03_Apartment1_tut1.rvt project created in Tutorial 1 in this chapter.
2. Interior wall type- Interior - 5” Partition (2-hr).
3. Location line parameter- Wall Centerline                                    
                                                                                                    
 The following steps are required to complete this tutorial:

a. Open the Apartment 1 project fi le created earlier in this chapter.
b. Invoke the Wall tool and select the Interior - 5” Partition (2-hr), refer to Figure 3-51.
c. Set the location line parameter as Location Line- Wall Centerline.
d. Select the Line sketching tool to sketch the straight walls. 
e. Sketch the interior walls based on the given parameters, refer to Figures 3-52 through 

Figure 3-58.
f. Edit the interior walls location to achieve clear internal distances, refer to Figures 3-59 

and Figure 3-60.

Figure 3-49  3D view of the completed exterior wall profi le

Tutorial 3               Apartment 1 - Interior Walls   
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Opening the Existing Project and Invoking the Wall Tool
1. Choose Open > Project from the Application Menu 

to open the c03_Apartment1_tut1.rvt project created 
earlier in this chapter.You can also download this fi le 
from: http://www.cadcim.com/Revit_2010/Revit_2010 .htm 
link.

2. Invoke the Wall tool from the Build panel in the Home 
tab of the ribbon. 

Selecting the Interior Wall Type
1. On invoking the Wall tool, the Place Wall tab is 

displayed. From the Element panel in this tab, select 
Interior - 5” Partition (2-hr) from the Change Element 
Type drop-down list, as shown in Figure 3-51. 

2. Ensure that the Location Line parameter in the 
Options Bar shows Wall Centerlines. Also, ensure that 
the Chain check box is cleared.

Sketching the First Interior Wall 
 After selecting the interior wall type, start sketching the 

interior walls. Notice that the Line option is selected 
as the default option for sketching the walls.

Figure 3-50  Layout of internal walls for Apartment 1 project

Figure 3-51  Selecting the Basic 
Wall : Interior-5”Partition (2-hr) 
wall type  
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1. Move the cursor near the top right endpoint of the wall structure. You will notice that a 
temporary dimension appears, which changes dynamically as you move the cursor away 
from it. This dimension shows the distance of the cursor from the nearest wall segment.

2. Enter 15’0” from the keyboard, as shown in Figure 3-52. Now press ENTER; the starting 
point of the fi rst interior wall is specifi ed. 

3. Next, move the cursor vertically downward near the lower exterior wall segment. When the 
Vertical and Nearest symbol appears, as shown in Figure 3-53, click to specify the location of 
the endpoint of the wall segment. The fi rst interior wall segment is sketched.

Sketching Other Interior Walls
 Similarly, you can sketch the other horizontal and vertical interior walls by specifying their 

start point and endpoint using different object snap options.
  

Figure 3-53  Specifying the endpoint of the fi rst interior wall segment

Figure 3-52  Specifying the distance for starting the fi rst interior wall segment
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1. To sketch the second interior wall, move the cursor to the upper endpoint of the interior 
wall you just created and then move the cursor horizontally toward the left. Enter 7’6”, 
when the temporary dimension and the intersection object snap appears, as shown in 
Figure 3-54. Now, press ENTER; the start of the second interior wall segment is specifi ed 
on the upper horizontal exterior wall. 

2. Press SHIFT and move the cursor downward. The cursor moves parallel to the vertical 
axis. Click near the lower external wall when the Vertical and Nearest symbol appears, 
as shown in Figure 3-55.

 Next, you will sketch the interior walls of the bath. Since the internal dimensions have 
been provided for the interior walls, you will fi rst sketch them using the wall centerlines 
and later move them to get the exact clearance distance of the bath walls.

3. Move the cursor to the lower left corner and then move it vertically upward. When the 
temporary dimension appears, enter 7’0” and press ENTER to select the starting point 
of the third interior wall, as shown in Figure 3-56.

4. Press SHIFT and move the cursor horizontally towards the right until it reaches the fi rst 
vertical interior wall. When the Horizontal and Nearest object snap symbol appears, click 
to specify the location of the endpoint of the third interior wall, as shown in Figure 3-57. 
The wall segment is created.

5. Similarly, move the cursor near the lower left corner and then move it horizontally 
toward the right. When the temporary dimension and the intersection object snap appears, 
enter the value 10’0”, as shown in Figure 3-58 and then press ENTER.

Figure 3-54  Specifying the starting point of the second interior wall 
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6. Press and hold the SHIFT key and move the cursor vertically upward until it reaches 
the horizontal interior wall. Click when the Vertical and Nearest symbol to specify the 
endpoint of the wall. Now, press ESC twice to fi nish the sketch of the wall.

Moving Walls Using Witness Lines
 As the dimension of the bath walls is from the centerline of the external walls, you need 

to move the interior walls of the bath such that the internal dimensions are 7’0”X10’0” 
as specifi ed in the sketch. Use the witness lines and specify these dimensions. 

1. Select the last created interior wall from the drawing. The selected interior wall shows the 
centerline distances and its controls.

2. Three blue square dots defi ne the extents of the dimensions. Click on the square dot on 
the extreme left. The dot and dimension witness line moves to the interior face of the 
exterior wall, as shown in Figure 3-59. 

Figure 3-56  Specifying the distance for sketching the third internal wall

   Figure 3-55  Sketching the second interior wall
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3. Similarly, click twice on the next square blue dot on the right to move it to the inner face 
of the third interior wall.  

4. Now, click on the temporary dimension, enter the value 10’0”, and then, press ENTER. 
The interior wall is moved to the desired distance 10’0” from the interior face of the 
exterior wall, as shown in Figure 3-60. 

5. Similarly, to move the horizontal interior wall of the bath, select it and move both the 
witness lines toward the inner face by clicking on the square blue dots.

6. Click on the temporary dimension from the lower external wall and enter the value 
7’0”, as shown in Figure 3-61 and press ENTER. The interior wall is moved to 
the desired location. Now, press ESC to exit the Modify Walls tab.

 7. This completes the interior wall layout for the Apartment 1 project. The model will look 
similar to that shown in Figure 3-61.

 Figure 3-58  Sketching the interior walls of the bath

 Figure 3-57  Sketching the third interior wall segment
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8. To view the building model in 3D, choose Create > 3D View from the View tab of the 
ribbon; a cascading menu is displayed. Now, from this cascading menu, choose Default 
3D View option; the 3D view of the building model is displayed along with the ViewCube 
tool. 

9. Now, choose the Model Graphics Style button from the View Control Bar; a fl yout is 
displayed. Choose the Shading with Edges option from this fl yout; the 3D view is displayed 
with shading with edges visible, as shown in Figure 3-62.  

10. Choose Save As > Project from Application Menu; the Save As dialog box is displayed. 
Enter c03_Apartment1_tut3 in the File name edit box and then choose Save.

Figure 3-61  Entering the value to adjust the dimension of the horizontal 
interior wall

   Figure 3-59  The square dot moved Figure 3-60 The adjusted inner wall 
distance   
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Create the interior walls of the left portion of the club building whose exterior wall profi le was 
created in Tutorial 2 earlier in this chapter. Create the walls, based on the sketch plan shown 
in Figure 3-63. The dimensions are given for the centerlines of the walls and are displayed 
only for drawing purpose. You do not need to dimension or add text to the building. The 
parameters to be used for different elements are given below.        (Expected time: 30 min)

1. Project- c03_Club_tut2.rvt project created in Tutorial 2 of this Chapter.
2. Interior wall type-Interior - 6 1/8” Partition (2-hr).
3. Unconnected height of walls- 12’0”.
4. Location Line- Wall Centerline.
5. Inclined walls are parallel to the external walls and perpendicular to each other.

 The following steps are required to complete this tutorial:

a. Open the c03_Club_tut2.rvt project fi le created in Tutorial 2 of this Chapter. 
b. Invoke the Wall tool and select the Interior - 6 1/8” Partition (2-hr) wall type, refer to 

Figure 3-64.
d. Set the unconnected height to 12’0” 
e. Verify that the location line parameter is set to Wall Centerline.
f. Select the Line sketching option to create the straight walls.
g. Sketch the interior walls based on the given parameters, refer to Figures 3-65 

through 3-71.

Figure 3-62  3D view of the Apartment 1 building model

Tutorial 4             Club - Interior Walls
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Opening the Existing Project and Invoking the Wall Tool
1. Open the  c03_Club_tut2.rvt project fi le by choosing Open > Projects from the Application 

Menu. You can also download this fi le from:
 http://www.cadcim.com/Revit_2010/Revit_2010.htm link.

2. Click twice on Level 1 under the Floor Plans node in the Project browser and invoke the 
Wall tool by choosing Build > Wall from the Home tab of the ribbon. 

Selecting the Interior Wall Type
 Before creating the interior walls you need to select the wall type using the Change 

Element Type drop-down list . 
 
1. Select Interior - 6 1/8” Partition (2-hr) from the Change Element Type drop-down list, 

as shown in Figure 3-64, in the Element panel of the Place Wall tab of the ribbon. 

2. Now, choose Element > Element Properties > Instance Properties in the Place Wall 
tab of the ribbon; the Instance Properties dialog box is displayed.

3. In the Value column for the Top Constraint parameter click to display a drop-down list 
and select the Unconnected option from it. 

4. Next, click on the value column of the Unconnected Height parameter, and replace the  
current value by entering the new value 12’0” in the cell.

Figure 3-63  Sketch plan for creating the interior wall of the left portion of the Club project
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5. Choose the OK button to close the Instance Properties 
dialog box.

Sketching the Interior Walls
 The interior walls to be created are straight in nature,  

therefore you can use the Line option from the Draw 
panel to create them. 

 1. Make sure that the Wall Centerline option is selected 
from the Location Line drop-down list in the Options 
Bar.

2. Also, clear the Chain check box, if  it is already selected 
in the Options Bar.

3. Move the cursor close to the lower left corner, marked 
as 6, refer to Figure 3-65, and traverse upward along the 
centerline of extreme left wall of the  building profi le. 
When the temporary dimension appears, enter the value 
10’0” and press ENTER to start the interior wall profi le 
from the specifi ed point, as shown in Figure 3-65.

4. Move the cursor 45-degree upward to the right. When a dashed line appears, enter the 
value 59’0”, as shown in Figure 3-66 and press ENTER.   

 
5. Start the next wall from the endpoint of the last wall by clicking on its endpoint. Move 

the cursor upward towards the left such that it subtends an angle of 135 degrees with the 
horizontal and it reaches the exterior wall displaying the Nearest object snap, as shown 
in Figure 3-67. Click to specify the endpoint of the wall. 

6. Similarly, to start the next interior wall, bring the cursor close to the start end of the last 
created wall (marked as 10), refer to Figure 3-67. Then move the cursor away along the 

Figure 3-64  Selecting the interior 
wall type from the Change Element 
Type drop-down list

               Figure 3-65  Specifying the start point of the fi rst interior wall 
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center of  the wall that is connected to the last created wall until the temporary dimension 
appears. When the temporary dimension appears, enter the value 10’0” and press ENTER 
to specify the start point of the wall.

7. Move the cursor upward towards the left such that it subtends an angle of 135 degrees with 
the horizontal until it reaches the exterior wall and the Nearest object snap is displayed, 
as shown in Figure 3-68. Click to specify the endpoint of the wall. 

8. Create the next wall by moving the cursor close to the last specifi ed point. Next, move 
it downward towards the right. When the temporary dimension appears, enter the value 
9’0” and press ENTER to start the wall, as shown in Figure 3-69. 

               Figure 3-67  Sketching the second interior wall

     Figure 3-66  Sketching the fi rst interior wall of the Club project
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9.  Move the cursor upward toward the right. Click on the exterior wall when the perpendicular 
object snap appears to specify the endpoint of the interior wall.

10. To create the next wall, bring the cursor close to the midpoint of the fi rst interior wall 
until the midpoint object snap appears, as shown in Figure 3-70. Click in the drawing to 
start the wall.

11. Move the cursor upward left toward the exterior wall such that it subtends an angle of 135 
degree with the horizontal and click when the nearest object snap appears on the exterior 
wall, as shown in Figure 3-71. Click to specify the endpoint and the wall is created.

  This completes the interior wall layout for the left portion of the Club project. 

12. Choose Save As > Project from Application Menu; the Save As dialog box is displayed. 
Enter c03_Club_tut4 in the File name edit box and then choose Save.

13. Now, choose Close from Application Menu to close the fi le.

Figure 3-69  Specifying the distance of the fourth 
interior wall 

Figure 3-68  Sketching the third interior wall 

Figure 3-70  Starting the fi fth interior wall from 
the midpoint of the fi rst interior wall

Figure 3-71  Completing the interior walls
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Answer the following questions and then compare them to those given at the end of this 
chapter:

1. You can modify the instance properties of a wall type in the Instance Properties dialog 
box. (T/F)

2. When you modify the instance properties of a wall, the instance properties of all the same 
wall types used in the project are modifi ed. (T/F)

3. You can create a wall type of your choice by combining various layers. (T/F)

4. By default, when you sketch a wall from left to right, the lower face becomes the external 
face. (T/F)

5. You cannot modify the angle of an inclined wall after sketching it. (T/F)

6. The  __________ dimension appears after you specify the start point of the wall and move 
the cursor.

7. You can use the __________ option to create a curved wall by specifying the center and 
the endpoints.

8. The __________ option enables you to sketch continuous wall segments that are connected 
end to end.

9. To create a wall starting at a specifi ed distance from a point on an existing element, you 
can use the __________ option from the Options Bar.

10. The required wall type can be selected from the available wall types displayed in the  
__________ drop-down list.

Answer the following questions:

1. The Location Line parameter is an instance property of a wall. (T/F)

2. The value of the Function parameter in the Type Properties dialog box for an exterior 
wall is Exterior. (T/F)

3. You can add or delete layers of a composite wall type to create a new wall type. (T/F)

Review Questions

Self-Evaluation Test
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4. Once a wall is sketched, its dimension and angle cannot be modifi ed. (T/F)

5. The Chain option can be enabled or disabled without exiting the wall tool. (T/F)

6. The usage of the wall can be changed by modifying the value of the Function parameter. 
(T/F)

7. While using the Wall tool, if you invoke any other tool, the Wall tool is 
discontinued. (T/F) 

8. Which of the following sketching tools can be used to create a straight wall?

  a) Lines    b) Circles
  c) Fillet Arc    d) Center-ends Arc

9. Which of the following keys can be used to constrain the cursor to move in the orthogonal 
direction?

  a) TAB     b) SHIFT
  c) ALT     d) F3 

10. Which of the following sketching tools can be used to create a curved wall? 

  a) Polygon    b) Line
  c) Fillet Arc    d) Rectangle

Create the exterior and interior walls of the Apartment 2, based on the Figure 3-72. The thick 
walls are the exterior walls and the thin walls are the interior walls. The dimensions and texts 
are not to be added. The project parameters for this exercise are given below.
                                  (Expected time: 30 min)

1. Project File - c02_Apartment2_ex1.rvt created in Exercise 1 of Chapter 2.
2. Exterior wall type- Exterior - Brick on Mtl. Stud
3. Interior wall type- Basic Wall: Interior - 5” Partition (2-hr).
4.  Height of the wall- Top Constraint - Upto Level 2.
5. Location line parameter for the exterior walls- Wall Centerline.
6. Name of the fi le to be saved- c03_Apartment_ex1

Exercise 1            Apartment 2

Exercises
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Figure 3-72  The sketch plan for creating the exterior and interior walls for the Apartment 2 project

Create the exterior walls of the Elevator and Stair Lobby project, based on the Figure 3-73. Do 
not add dimensions or texts as they are only for reference. The project parameters for this 
exercise are given next.                       (Expected time: 30 min)
                   
1. Project File - c02_ElevatorandStairLobby_ex2.rvt created in Exercise 2 of Chapter 2.
2. Exterior wall type- Basic Wall Exterior Brick on Mtl. Stud.
3.  Height of the wall- Top Constraint- Upto Level 2.
4. Location line parameter- Wall Centerline.
5. Name of the fi le to be saved- c03_Elevator and StairLobby_ex2

Exercise 2                    Elevator and Stair Lobby
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Figure 3-73  Sketch plan for creating the exterior walls for the Elevator and Stair Lobby project

Create the interior walls of Hall 2 of the Club project based on Figure 3-74. Do not dimension the 
sketch as these are only for reference. The project parameters for this exercise are given 
next.                                                                          (Expected time: 30 min)
                   
1. Project File - c02_Club_ex3.rvt created in Tutorial 2 of this chapter.
2. Interior wall type- Basic Wall: Interior - 6 1/8” Partition (2-hr).
3. Unconnected height of walls- 12’0”.
4. Location Line- Wall Centerline.
5. Inclined walls are parallel to the external walls and perpendicular to each other.
6. Name of the fi le to be saved- c03_Club_ex3

Exercise 3                             Club-Interior Walls
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Figure 3-74  Sketch plan for sketching the interior walls of right portion for the Club project

Answers to Self-Evaluation Test
1. T, 2. F, 3. T, 4. F, 5. F, 6. Temporary, 7. Center- ends Arc, 8. Chain, 9. Offset, 10. Change 
Element Type 
































































