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MicroStation Design Files

Module Overview

This module discusses aspects of working with design files.

Module Prerequisites

• Knowledge of MicroStation’s interface

• Some knowledge about MicroStation design elements

• Knowledge about viewing in MicroStation

Module Objectives

After completing this module, you will be able to:

• Save information

• Create files using seed files

• Set working units

• Compress files

• Create Saved Views

Introductory Knowledge

Before you begin this module, let's define what you already know.
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Questions

1 What happens when you turn off display of a level?

2 True or False: View controls can only be applied to the view from which 
the tool was chosen.

Answers

1 Turning levels on or off changes the display status of the elements that 
reside on the level.

2 False. You can use a view control in any view.

MicroStation Design Files

Design file, or DGN, is the name of MicroStation’s primary data storage file, due to 
the .dgn file extension. The term design is often used interchangeably with the 
term design or drawing. 

However, a design is a collection of elements that are drawn at full scale. A 
drawing is a collection of elements and other items assembled for presentation 
purposes.

Closing Files

You have finished with the file you are in and want to close it. There is still more 
work to do in MicroStation though, so you don’t want to quit the application. You 
just want to close the current design file.

• Selecting File > Open lets you select the next file you wish to open. The file 
you are currently using will close and the new file will open.

• Selecting File > Close will close the current file, returning you to the File Open 
dialog.

 Exercise: Closing the active design file

1 Continuing in the present model, select File > Close from the main menu 
bar.

The design file closes and you are returned to the File Open dialog.
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You can only open one design file at a time in a MicroStation session. If you find 
that you need to have two design files open at the same time, you must start a 
second MicroStation session to open the second design file. It is a good practice 
to select a different User in the File Open dialog when opening the second 
session. Note that only one license is used for both sessions. 

Saving information

The method MicroStation uses to save information is slightly different from the 
methods other applications use. When you open a design for modification in 
MicroStation, the program reads the design’s data from the design file stored on 
the system’s hard disk or network device into the computer’s local memory 
(RAM). During the design process, MicroStation periodically writes the changes 
back (saves) to the open file on the hard drive. This contrasts with other 
applications that require you to perform a Save operation to permanently save 
your changes.

Creating a MicroStation design file

To work in MicroStation you must either open an existing design file or create a 
new one. In the next exercise, you will create a MicroStation design file and give it 
a name before opening it. You will use the File Open dialog to create the file, but 
you can create a file from inside MicroStation by selecting File > New.

Hint: A benefit of creating a file from inside MicroStation is that the new file opens 
immediately.

 Exercise: Creating a new file

1 Click the New file icon at the top of the File Open dialog.

2 Type myfile in the File name field of the New Design File dialog.

Do not press Enter yet. Doing so is the same as clicking OK or Save, which 
will finish the creation process and close the dialog you are using.

3 Observe the Save as type field.

It is set to MicroStation DGN Files. This field is used to select the desired 
file type. The correct extension will be appended to the file name 
automatically.

4 Observe the Seed field, and then click the Browse button.
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It shows the path to the seed file that will be used; in this case, it is called 
ExampleSeed.dgn.

Other delivered seed files are in the folder. To use one, select it and click 
Open.

5 Click Cancel to continue to use ExampleSeed.dgn.

6 Click Save.

The new file name, myfile.dgn, appears in the File Open dialog.

You can open existing MicroStation files and create new files from your own 
workstation or any accessible device on your network that has access to a 
MicroStation license. Your system administrator, CAD manager or project leader 
will probably set the location of your project’s files.

Now that you have created a new design file, open it and see what is inside.

 Exercise: Opening the new file

1 With myfile.dgn selected in the File Open dialog, click Open to open the 
file.

You see any elements that were present in the seed file.

2 Select File > New from the main menu bar.

Seed files

A new design file is created by copying an existing seed file, which serves as a 
template. It contains preset values such as initial element parameters, the type of 
design to be created (2D or 3D), the working units used and perhaps some initial 
design elements. An example of the latter would be a seed file containing your 
company’s sheet border and title block. 

 Exercise: Selecting a seed file

1 Click the Browse button next to the Seed field at the bottom of the New 
file dialog.

2 In the Select Seed File dialog, select 2dMetricGeneral.dgn.

3 Click Open.

4 Type myfile2 in the File name field of the New file dialog.
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5 Click Save.

The file opens. You can see that this seed file contains no elements.

Note: If you try to use a file name that already exists, an alert appears, warning you 
the file already exists. You will overwrite the file if you continue with file 
creation. When such a window appears, play close attention and make sure you 
really want to overwrite the file. 

The MicroStation installation contains many useful standard seed files. They are 
located in the \WorkSpace\System\seed folder. Use the Look in field at the top of 
the File Open dialog to navigate through folders.

Hint: You can click the Up One Level icon to move up one folder from the present 
one.

As you have seen, seed files can contain geometry or they can be pre-configured 
with many of the standards common to a particular project. Your CAD manager or 
project leader will probably customize certain delivered seed files for your use. 
Having the customized seed files will make it easier for you to adhere to required 
project parameters.

Working with Files

Attributes settings affect individual elements placed in a design file. Some settings 
and operations affect everything in the file, or the file itself.

Setting working units

Working units are real-world units to which the design plane is configured. 

MicroStation uses true working units that are based on the meter. All 
measurement information is stored in the metric system and converted to other 
systems when requested. The conversion is completed with 14 places of accuracy 
to the right of the decimal point. You use units of measure, selecting the preferred 
units from a collection of imperial and metric units. 
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Changing units in a model does not change the physical size of the design 
geometry. It simply changes the display of measured distances to the units of 
choice.

Working units are composed of Master Units (MU) and Sub Units (SU), for 
example, meters and centimeters. Sub units must always be equal to, or smaller 
than, the master unit.

Working units, and how they are reported, are set in the Design File Settings 
dialog. Select Settings > Design File, then the Working Units category.

• The Master Unit and Sub Unit options are set by the system and can be edited 
by an administrator.

The Format and Accuracy settings are used when displaying coordinates, 
distances, and angles in the status bar and dialogs. Setting these does not 
affect the accuracy of calculations, only the precision with which the Format 
options establish which units are displayed. MU displays only the master units. 
MU:SU displays both master and sub units.

For example, one and a half feet is 1.5 feet, or two meters and 750 millimeters 
is 2.75 meters.

• Accuracy sets the number of decimal places, or fractional accuracy readout.

You can change working units quickly in the Drawing Scale dialog. Select Settings > 
Drawing Scale to open it.

Note: Any changes made in the Design File Settings and Drawing Scale dialogs must 
be saved by selecting File > Save Settings.

Working Units MU:SU and Distance

Feet / Inches 120:10 is 120 feet, 10 inches

Miles / Yards 26:385 is 26 miles, 385 yards

Meters / Millimeters 5:25 is 5 meters, 25 millimeters

Millimeters / Micrometers 0:500, or:500 is one half millimeter
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Compressing files

Compressing a design file reduces its size by purging empty and unused data 
resources. Select File > Compress > Design to compress a file. Note that this clears 
the undo buffer, so you will no longer be able to undo and redo.

Storing Geometry

Models

A model is a separate working space within a design file. MicroStation design files 
can contain multiple models. Models contain separate geometry within a design 
file.

Saved Views

A Saved View is a named view definition saved in a DGN file. It is a way to store a 
specific area of a design along with view attributes, window size and position, and 
other settings. You save the portion of the design you want to reuse and then 
attach it to any view window when needed. You can also attach a saved view to 
another model as a reference.

Hint: Saved Views are often used to set up standardized views for plotting.

You can create a clip volume during the process of creating a saved view or create 
a saved view from an existing clip volume. A clip volume is used to limit the 
displayable area of a design using the boundaries of a closed shape or a defined 
area. When clip volume is applied to a view, only the area within the defined 
boundary is displayed. Each of MicroStation’s eight views can have a different clip 
volume.

 Exercise: Limit the elements displayed using a clip volume

1 Open MicroStation_Essentials_V8i.dgn.

If you are in the same MicroStation session, you can use the Previous 
Model tool at the lower left of the application window to return to the last 
model that was open in the file.

2 Open the model named Office Building, description, Essentials geometry.
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3 Select the Clip Volume view control from View 2, with the following tool 
setting:

Apply Clip Volume By Element: Enabled

Display Clip Element: Enabled (you see the element that defines the area)

Create Dynamic View: Disabled

4 Click on the green shape around the stairwell.

The stairwell is displayed.

5 Turn off the level named Stairwell.

6 Expand the Clip Volume tool settings by clicking on the downward arrow 
at the lower right. 

This area lets you save a clip volume for future recall.

7 Click Create Named Fence from Clip Volume in the tool settings.

8 Replace Untitled with Stairwell and press Enter.

This saves the displayed area so that it can be reused.

 Exercise: Create a saved view

1 Continuing in the Office Building model, maximize View 2.

2 Click the Saved Views tool in the Primary toolbox to open the Saved Views 
dialog.

3 Click Create Save View in the Saved Views dialog, and set the following:
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Method: From View

View Type: Saved View

Name: Stairs

Clip Volume: select Stairwell

Associative Clip Volume: Enabled

4 Enter a data point in the view.

A pop-up message indicates the view is created.

5 Click the Restore Down icon at View 2’s upper right to size the view back 
down.

 Exercise: Applying a saved view

1 Continuing in the Office Building model, open View 8.

2 Make sure the Saved Views dialog’s title bar indicates that View 8 is the 
view to which changes will be applied.

Hint: If you want to change the view to which the saved view is applied, just 
click its title bar.

3 Scroll to and select the Stairs view in the list of names and click Apply 
Saved View.

4 Note the tool settings. (Do not click in the view to apply the saved view 
yet.)

Apply Saved View Options

There are several parameters saved with a saved view. Window size and position, 
aspect ratio, reference settings, levels, camera position, view attributes, and clip 
volume. Enable or disable these options when you apply a saved view to retain or 
discard parameters.

When the Window icon is enabled, setting the option menu to its right to Aspect 
Ratio keeps the saved view proportionate. Selecting Size keeps it the same size, or 
a 1:1 ratio. Selecting Size and Position keeps the exact size and position.
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Enable View Attributes so that the saved view’s view attribute settings are 
maintained, rather than accepting those that are active in the view to which it is 
being attached.

The other options work the same way. If the icon is enabled the saved view will 
maintain its own parameters as opposed to accepting those that are active in the 
view to which it is being attached.

 Exercise: Attach the saved view

1 Click the Window icon and set the option to Size and Position.

2 Enter a data point in View 8.

The saved view is attached and the view window resizes so that it is the 
same as it was when the saved view was created.

3 Close the Saved View dialog.

4 Click the Restore Down icon at View 8’s upper right to size the view back 
down.

 Exercise: Test the associative clip volume

1 Continuing in the Office Building model, select the Scale tool form the 
Main toolbox with the following tool settings:

X Scale: 2.00

Y Scale: 2.00

Z Scale: 2.00

2 In View 2, the clipped view, scale the block that defines the clip area.

The saved view updates.
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Ending a MicroStation Session

MicroStation does not immediately write changes to design file settings or 
attribute settings to disk.

Save Settings

When you make changes to settings that you want to permanently store, you 
must save them to disk. To do this, select Save Settings from the File menu on the 
main menu bar. A shortcut exists for this command as noted in the File menu, Ctrl 
+ F.

Save Settings saves the current settings in the active design file. These settings 
include those that you set in file settings dialogs, as well as the view 
configuration. The view windows will look exactly the same in size, position, and 
content when you reopen them if you Save Settings before you close a file.

Tips and Tricks

• When making many design changes in a file, it may be helpful to place a 
bookmark so that you can undo changes back to a particular point. Referred to 
as a mark, you can set it by selecting Edit > Set > Set Mark. This puts a marker 
in the undo buffer so that you can undo your work back to that point by 
selecting Edit > Undo Other > To Mark. You can have multiple marks in one file, 
so you can do some work, mark it, do some more, mark there and so on.

• You can change the label that is displayed with working units. Select Settings > 
Design File and select the Working Units category. Simply select the unit label, 
type in what you want, and click OK.

• The File menu on the main menu bar has a history of files you have opened at 
the bottom. This makes it easy to locate a specific file you used previously.
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Module Review

Now that you have completed this module, let’s measure what you have learned. 
You can test your skill using the geometry in the MicroStation Design Files 
Challenges, Test Your Skill, model.

Questions

1 New design files are based upon what kind of files?

2 What is the difference between a design and a drawing?

3 What are working units?

4 True or False: Changing units in a model changes the physical size of the 
design geometry.

5 Name two things saved with a Saved View.

6 True or False: You can save a clip volume so that it can be recalled.


